Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5563 - installer fails to upgrade if WinNT NTFS partition is present
Summary: installer fails to upgrade if WinNT NTFS partition is present
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-05 05:13 UTC by fromredhat
Modified: 2015-01-07 23:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-05 15:27:04 UTC


Attachments (Terms of Use)

Description fromredhat 1999-10-05 05:13:43 UTC
problem manifests in python installer script in /site-
packages/ directory

from todo.py

...
    def upgradeFindRoot (self):
        rootparts = []
        if not self.setupFilesystems: return [
self.instPath ]
        win = self.intf.waitWindow (_("Searching"),
                                    _("Searching for Red
Hat Linux installations..."))

        drives = self.drives.available ().keys ()
        self.ddruid = FakeDDruid ()
        for drive in drives:
            isys.makeDevInode(drive, '/tmp/' + drive)

            try:
                table = _balkan.readTable ('/tmp/' + drive)
            except SystemError:
                pass
            else:
                self.ddruid.append (drive, table)
                for i in range (len (table)):
                    (type, sector, size) = table[i]
                    # 2 is ext2 in balkan speek
                    if size and type == 2:
...

balkan returns type == 2 for NTFS volumes, thus the rest of
this function will attempt to mount the partition and fail
out when that doesn't work. Need to fix balkan or whatever
to return a different value for NTFS or otherwise check the
partition type before trying to mount it. Oh yes - "speek"
is, oph kourse, speeled "speak" :-)

-greg

Comment 1 Bill Nottingham 1999-10-05 15:27:59 UTC
*** This bug has been marked as a duplicate of 5567 ***


Note You need to log in before you can comment on or make changes to this bug.