Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5558 - Old microsoft mouse wasn't detected
Summary: Old microsoft mouse wasn't detected
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-05 03:14 UTC by eckman
Modified: 2015-01-07 23:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-12-01 21:07:03 UTC


Attachments (Terms of Use)

Description eckman 1999-10-05 03:14:01 UTC
I tried 3 different mice with the redhat 6.1 X-install
program, but they all happened to be 2-button serial MS (or
MS compatible) mice. None of them were detected.  The newest
of the mice is a revision 2.0A MS mouse.

The X-install program isn't very non-mouse friendly I'm
afraid.  (I submitted a bug report about that already.)

I hard-coded my setting into the
instimage/usr/lib/python1.5/site-packages/xserver.py file on
my NFS server to get my install to work.  Not a solution for
everyone.  :)

Thanks!

Eric

Comment 1 Jay Turner 1999-10-20 18:53:59 UTC
What happens when you select the mouse that you have in the mouse
config screen?  The installer should work without any problems with a
PS/2 mouse or a serial mouse.  Submit more details of the problems
which you are seeing.

------- Additional Comments From   10/26/99 17:23 -------

I ran a few tests on the machine and I now have a better idea what's
happening.

My computer doesn't have a PS/2 mouse port (AMD K6-300, motherboard
has intergraded sound and video).  On bootup, the linux kernel is
detecting a PS/2 mouse port.  During the install, the hardware
detection program (a python lib in this case), kudzu, thinks that the
computer has a PS/2 mouse.  Kudzu thinks that the $mouseDev is
"psaux", the $driver is "ignore" and the $description is "Generic PS/2
Mouse."  Needless to say kudzu and the kernel are both a little
confused.

As for selecting the correct mouse from the mouse config screen, I do
that and it doesn't magicly cause my mouse to start working.  It
should probably restart X with the new mouse settings, but that
doesn't happen.

I hope that helps.

Eric

Comment 2 Jay Turner 1999-12-01 21:07:59 UTC
There are known bugs with the installer detecting PS/2 mice which are not
actually there because the installer is seeing a PS/2 port and just assuming
there is a mouse attached.  We are currently trying to come up with the best
solution for this problem.

As for making a change to your mouse and having the change take effect, you will
need to restart gpm as well as X to pick up the changes.

*** This bug has been marked as a duplicate of 6415 ***


Note You need to log in before you can comment on or make changes to this bug.