Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5556 - False SMP Multi Processor Detection bug
Summary: False SMP Multi Processor Detection bug
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-05 02:23 UTC by ikes
Modified: 2015-01-07 23:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-20 18:46:24 UTC


Attachments (Terms of Use)

Description ikes 1999-10-05 02:23:54 UTC
After completing an upgrade from RH6.0 to RH6.1 on a 200Mhz
Pentium MMX SINGLE PROCESSOR machine on a dual processor
mother board (Tyan TomcatIV), the installer automaticly
installed an SMP kernel, which then prevented the machine
from booting.  (We used the graphical installer from an NFS
image on the local lan, options were DHCP & etherlink III)

Ike Stewart

Comment 1 ikes 1999-10-05 02:39:59 UTC
Additional information, it appears that the installer re configured
lilo so the the default "linux" option linked to the SMP kernel, but
also left a "linux-up" (uni-processor?) option that does result in the
machine booting the single processor kernel.

------- Additional Comments From   10/10/99 14:48 -------
Same problem on SuperMicro P6DGE motherboard. SMP Kernel installed
also does not perform power off with poweroff or halt commands.

Comment 2 Jeremy Katz 1999-10-13 04:05:59 UTC
APM poweroff is not a safe operation to do under SMP (actually, APM
isn't defined at all under SMP).  Therefore, it doesn't do so.

The installer did correctly and detected the dual processor
motherboard; there is no way to know if there is a processor in the
slot.

Comment 3 Alan Cox 1999-10-15 20:20:59 UTC
Its up to the BIOS to avoid providing a table for 2 CPUs when there
is not a dual CPU setup present. If the BIOS doesn't ask the vendor
for an upgrade. Because some of these boards assumed the table is
burned into ROM you may however be out of luck.

Comment 4 Jay Turner 1999-10-20 18:46:59 UTC
The installer is looking for an SMP capatible motherboard, and upon
finding that, will install the SMP kernel and make it the default. The
solution to the problem is to boot the uniprocessor kernel (which is
installed as well by default . . . just type "linux-up" at the lilo
prompt) and then modify /etc/lilo.conf to remove the entry for the SMP
kernel and then rerun lilo to affect the change.


Note You need to log in before you can comment on or make changes to this bug.