Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 552233 - NetworkManager disabled...
Summary: NetworkManager disabled...
Keywords:
Status: CLOSED DUPLICATE of bug 589108
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 12
Hardware: i686
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-04 12:46 UTC by Plug Gulp
Modified: 2010-05-18 00:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-18 00:10:11 UTC


Attachments (Terms of Use)

Description Plug Gulp 2010-01-04 12:46:34 UTC
Description of problem:
With latest update of Fedora 12, the system has become unstable. NetworkManager is altogether disabled and the system freezes. I had to do hard reboot after few seconds. The NetworkManager package is NetworkManager-1:0.7.996-6.git20091021.fc12
The kernel is 2.6.31.9-174.fc12.i686.PAE. The crash manager notifies of the kernel crash and dmesg shows an error: "[drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own"

Version-Release number of selected component (if applicable):
NetworkManager-1:0.7.996-6.git20091021.fc12
Kernel 2.6.31.9-174.fc12.i686.PAE

How reproducible:
No specific procedure, just restart the system after an update from 03 Jan 2010.

  
Actual results:
NetworkManager is disabled and system freezes.

Expected results:
NetworkManager should be enabled and system should not freeze.

Additional info:

Comment 1 Dan Williams 2010-01-16 19:53:59 UTC
The system freeze appears to be DRM/graphics related and not NetworkManager related actually.

When you say "network manager is disabled", what specifically do you mean?  Is the 'Networking enabled' checkbox in the nm-applet right-click menu unchecked?  Or something else?

If you can, can you grab the kernel log messages with a command like this typed into a terminal:

dmesg > /tmp/kernel.log

and then attach that file to this bug report?

Comment 2 Plug Gulp 2010-01-26 12:41:53 UTC
(In reply to comment #1)
> The system freeze appears to be DRM/graphics related and not NetworkManager
> related actually.
> 

Yep, sorry for that. I stumbled across two problem at the same time, the Networkmanager issue and the drm error. Someone has already logged a bug related to drm in bugzilla.

> When you say "network manager is disabled", what specifically do you mean?  Is
> the 'Networking enabled' checkbox in the nm-applet right-click menu unchecked? 
> Or something else?
> 

The "Networking enabled" checkbox gets automatically disabled after update. And there is no notification that the checkbox has been disabled.

> If you can, can you grab the kernel log messages with a command like this typed
> into a terminal:
> 
> dmesg > /tmp/kernel.log
> 
> and then attach that file to this bug report?    

As the bug is already in the database, I will avoid duplicating it here.

Thanks and regards,

~Ajit

Comment 3 Dan Williams 2010-05-18 00:10:11 UTC

*** This bug has been marked as a duplicate of bug 589108 ***


Note You need to log in before you can comment on or make changes to this bug.