Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 551972 - 539904
Summary: 539904
Keywords:
Status: CLOSED DUPLICATE of bug 508422
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 11
Hardware: i586
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-03 12:47 UTC by Juergen Bullinger
Modified: 2014-01-21 23:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-03 15:52:27 UTC


Attachments (Terms of Use)

Description Juergen Bullinger 2010-01-03 12:47:07 UTC
Description of problem:
yum update crashes with the message

UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 123: ordinal not in range(128)

The problem persists even after I performed

yum clean all

See additional info for the complete traceback yum printed on the console.


Version-Release number of selected component (if applicable):

[root@localhost tv]# yum --version
3.2.24
  Installiert: rpm-4.7.1-3.fc11.i586 am 2009-11-04 21:37
  Gebaut    : Fedora Project am 2009-10-08 09:53
  Übermittelt: Panu Matilainen <pmatilai@redhat.com> am 2009-10-08 12:00

  Installiert: yum-3.2.24-2.fc11.noarch am 2009-10-10 13:26
  Gebaut    : Fedora Project am 2009-09-21 19:27
  Übermittelt: Seth Vidal <skvidal at fedoraproject.org> am 2009-09-21 12:00

  Installiert: yum-metadata-parser-1.1.2-12.fc11.i586 am 2009-08-16 11:17
  Gebaut    : Fedora Project am 2009-02-25 18:45
  Übermittelt: Fedora Release Engineering <rel-eng@lists.fedoraproject.org> am 2009-02-25 22:00


How reproducible:
100%

Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:
yum exits after printing an error message and a traceback (see additional info)

Expected results:
yum should update the installed packages to the latest version

Additional info:
Might this be related to Issue 539904?

Here is the complete traceback:

[root@localhost tv]# yum update
Geladene Plugins: dellsysidplugin2, refresh-packagekit
adobe-linux-i386                                                   |  951 B     00:00     
adobe-linux-i386/primary                                           |  12 kB     00:00     
adobe-linux-i386                                                                    17/17
fedora/metalink                                                    |  29 kB     00:00     
fedora                                                             | 3.8 kB     00:00     
fedora/primary_db                                                  | 8.4 MB     00:14     
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 311, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 180, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 349, in doCommands
    self._getTs(needTsRemove)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 100, in _getTs
    self._getTsInfo(remove_only)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 111, in _getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 702, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 538, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 277, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 164, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 222, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1222, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1386, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1378, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1368, in _loadRepoXML
    return self._groupLoadRepoXML(text, ["primary"])
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1351, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1197, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 976, in _getFileRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 797, in _getFile
    result = self.grab.urlgrab(misc.to_utf8(relative), local,
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 498, in <lambda>
    grab = property(lambda self: self._getgrab())
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 493, in _getgrab
    self._setupGrab()
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 482, in _setupGrab
    self._grab = mgclass(self._grabfunc, self.urls,
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 655, in <lambda>
    urls = property(fget=lambda self: self._geturls(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 652, in _geturls
    self._baseurlSetup()
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 606, in _baseurlSetup
    mirrorurls.extend(self._getMirrorList())
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1625, in _getMirrorList
    print "Could not retrieve mirrorlist %s error was\n%s" % (url, e)
  File "/usr/lib/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 123: ordinal not in range(128)

Comment 1 Tim Lauridsen 2010-01-03 15:52:27 UTC
Fixed in yum 3.2.25

*** This bug has been marked as a duplicate of bug 508422 ***

Comment 2 Juergen Bullinger 2010-01-03 17:44:46 UTC
How can I now update my system?

I did yum update just some days ago. It still worked then. But how could this problem still occur, if my system (including yum) is at most a few days behind the current package versions and you fixed that bug already in october?

Comment 3 Tim Lauridsen 2010-01-04 08:28:07 UTC
Look like 3.2.25 is only released in Fedora 12.

Seth, it there any reason for 3.2.25 not to go into F11 ???

Comment 4 seth vidal 2010-01-04 14:47:04 UTC
the history stuff seems like a fairly sizeable change to poke back at people.


Note You need to log in before you can comment on or make changes to this bug.