Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5517 - samba-common missing files after upgrade
Summary: samba-common missing files after upgrade
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-04 21:49 UTC by Ian Macdonald
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-29 18:36:39 UTC


Attachments (Terms of Use)

Description Ian Macdonald 1999-10-04 21:49:52 UTC
After upgrading from RHL 6.0 to 6.1, samba no longer worked.
Here's why:

[root@caliban ~]# rpm -V samba-common
missing    /etc/codepages
missing    /etc/codepages/src
missing    /etc/codepages/src/codepage_def.437
missing    /etc/codepages/src/codepage_def.737
missing    /etc/codepages/src/codepage_def.850
missing    /etc/codepages/src/codepage_def.852
missing    /etc/codepages/src/codepage_def.861
missing    /etc/codepages/src/codepage_def.866
missing    /etc/codepages/src/codepage_def.932
missing    /etc/codepages/src/codepage_def.936
missing    /etc/codepages/src/codepage_def.949
missing    /etc/codepages/src/codepage_def.950
missing    /etc/smb.conf

Comment 1 Bill Nottingham 1999-10-04 21:52:59 UTC
Exactly which version of samba did you have previously?

Comment 2 Ian Macdonald 1999-10-04 21:55:59 UTC
I was using samba-2.0.5a-1.i386.rpm, which was an official update to
the stock RPM included with RHL 6.0.

Comment 3 Bill Nottingham 1999-10-04 22:01:59 UTC
Did you modify the config file at all?

Comment 4 Bill Nottingham 1999-10-04 22:16:59 UTC
Do you have an /etc/smb.conf.rpmsave?

Comment 5 Ian Macdonald 1999-10-04 22:27:59 UTC
Yes, I had modified the /etc/smb.conf and yes, it had been saved as
/etc/smb.conf.rpmsave

Comment 6 Bill Nottingham 1999-10-05 15:21:59 UTC
OK. It's some RPM weirdness; we're looking into it.
I can't reproduce the codepages being missing; they still
should be created by the %post script.

Comment 7 Jeff Johnson 2001-01-09 15:21:26 UTC
This was a problem with transaction sets before (IIRC) rpm-3.0.2, long since
fixed.


Note You need to log in before you can comment on or make changes to this bug.