Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5507 - Installer fails because of misdetected NTFS-partitions
Summary: Installer fails because of misdetected NTFS-partitions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-04 19:51 UTC by ville.sulko
Modified: 2015-01-07 23:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-05 18:55:21 UTC


Attachments (Terms of Use)

Description ville.sulko 1999-10-04 19:51:45 UTC
Anacondas balkan falls through in NTFS-patrition detection,
which causes NTFS-partitions to be detected as EXT2. This in
turn breaks the install in upgradeFindRoot, causing a jammed
upgrade. Fix by adding the missing 'break' statement into
.../misc/src/anaconda/balkan/dos.c line #142 (I think! :).


------- Additional Comments From   10/05/99 06:19 -------
I can confirm this problem (hda1 is NTFS, anaconda stops and hangs
there while searching my root fs for upgrading).

Comment 1 Trond Eivind Glomsrød 1999-10-05 11:58:59 UTC
Here is a patch, which should apply to bugs 5507, 5555, 5563, 5552 and
5567 (making changes to several of these at once didn't work).

A break statement is missing after detecting a NTFS-partition, thus
identifying it as an EXT2FS-partition.
--- /mnt/cdrom/misc/src/anaconda/balkan/dos.c   Sat Sep 11 17:47:28
1999
+++ dos.c       Tue Oct  5 13:34:16 1999
@@ -139,6 +139,7 @@

              case 0x7:
                table->parts[i].type = BALKAN_PART_NTFS;
+               break;

              case 0x83:
                table->parts[i].type = BALKAN_PART_EXT2;






------- Additional Comments From   10/05/99 08:48 -------
I just run into the same bug on the 6.1 Cartman.
hda1 is NTFS, install stops, complains something like no ext2fs on
hda1, and hangs.

Also, seen on colleagues machine: hda1 was an old swap partition,
install (Cartman) complained of lack of space, and kept trying to
format the / partition... Sorry, no precise details on this. Related?



   Heikki Levanto, Index Data, Denmark
   heikki@indexdata.dk

Comment 2 Bill Nottingham 1999-10-05 18:55:59 UTC
*** This bug has been marked as a duplicate of 5567 ***


Note You need to log in before you can comment on or make changes to this bug.