Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5471 - remote logging breaks with sysklogd-1.3.31-11.i386.rpm
Summary: remote logging breaks with sysklogd-1.3.31-11.i386.rpm
Keywords:
Status: CLOSED DUPLICATE of bug 5462
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: sysklogd
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-01 22:20 UTC by trouble
Modified: 2014-03-17 02:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-01 22:33:32 UTC


Attachments (Terms of Use)

Description trouble 1999-10-01 22:20:19 UTC
Two RH6.0 machines seem to have no remote syslog after
upgrading to
sysklogd-1.3.31-11.i386.rpm. Downgrading to
sysklogd-1.3.31-6.i386.rpm
fixes remote reception.

I upgraded because I'm having problems with syslog/klog
(1.3.31-6)
getting in a bad state while remotely logging a sonicwall
firewall.
This "bad state" causes login to hang, apparently waiting on
klogd. If I
(re)start klogd (sometimes it's already dead), the login
proceeds. This
machine is also logging 4 jetdirect boxes. During this bad
state, all
logging stops.

The other RH6.0 machine is logging only one jetdirect box
and hasn't
shown this problem.

I enable remote reception by adding the "-r" switch to the
command line
in /etc/rc.d/init.d/syslog.

# See how we were called.
case "$1" in
  start)
    echo -n "Starting system logger: "
    # we don't want the MARK ticks
    daemon syslogd -r -m 0
    echo
    echo -n "Starting kernel logger: "
    daemon klogd
    echo
    touch /var/lock/subsys/syslog
    ;;

Comment 1 Bill Nottingham 1999-10-01 22:33:59 UTC
*** This bug has been marked as a duplicate of 5462 ***


Note You need to log in before you can comment on or make changes to this bug.