Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 54433 - unable to use itkwish
Summary: unable to use itkwish
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcltk
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: David Lawrence
URL:
Whiteboard:
: 62044 76391 76497 84011 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-08 11:44 UTC by Leonid Kanter
Modified: 2007-04-18 16:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-16 08:09:11 UTC


Attachments (Terms of Use)

Description Leonid Kanter 2001-10-08 11:44:06 UTC
Description of Problem:

[leon@leon program]$ itkwish
Segmentation fault


Version-Release number of selected component (if applicable):

itcl-3.2-65

How Reproducible:

always

Comment 1 Eido Inoue 2001-10-17 17:41:01 UTC
Ugh. This creeped back in.

itcl 3.2 does not include the itkwish and itclsh by default-- they've been
depreciated by the itcl author in favor of loading them with a "requires"
through the regular tclsh and wish shells. itkwish and itclsh are included with
3.2 for backwards compatibility with the earlier Red Hat.

Will fix-- but expect (in other words, migrate or plan to migrate to the
solution above if possible) itkwish and itclsh to go away when the next major
(non-dot) release of Red Hat is released and neither shell is included in itcl
3.2 anymore anyway.


Comment 2 Mike McLean 2002-10-25 14:28:40 UTC
The last comment is pretty old... has this been fixed yet, or should it be
marked wontfix?

Comment 3 Mike McLean 2002-10-25 14:29:32 UTC
*** Bug 76391 has been marked as a duplicate of this bug. ***

Comment 4 Jens Petersen 2002-10-27 02:37:54 UTC
Hmm, I believe I already have a fix for this, but I am actually leaning
towards dropping "itclsh" and "itkwish" in the next package release.
Would that hurt people?

Comment 5 Bill Nottingham 2002-10-29 04:03:16 UTC
If they're deprecated upstream, I don't have much problem with removing them.
But if we include them they shouldn't segfault. :)

Comment 6 Mike McLean 2002-10-29 15:14:31 UTC
Since this bug is also in 8.0, I am updating the version (was 7.3).

Comment 7 Jens Petersen 2002-11-11 05:43:59 UTC
*** Bug 76497 has been marked as a duplicate of this bug. ***

Comment 8 Jens Petersen 2002-11-11 05:45:54 UTC
This will get fixed shortly.  Thanks for your patience.

Comment 9 Jens Petersen 2002-12-03 15:36:23 UTC
*** Bug 62044 has been marked as a duplicate of this bug. ***

Comment 10 Jens Petersen 2002-12-10 07:58:54 UTC
You should be able to use itcl and itk from tcl and wish
in package release 77 and later (perhaps even 76).
The source package is tcltk-8.3.5-77.

As indicated above the obsolete itclsh and itkwish aren't
being included any longer.


Comment 11 Jens Petersen 2003-02-21 08:27:28 UTC
*** Bug 84011 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.