Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5442 - Netscape dies when any attempt is made to use java.
Summary: Netscape dies when any attempt is made to use java.
Keywords:
Status: CLOSED DUPLICATE of bug 2711
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netscape
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL: unimportant
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-29 20:09 UTC by wdc
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-29 20:13:45 UTC


Attachments (Terms of Use)

Description wdc 1999-09-29 20:09:04 UTC
Repeat by:
	Start netscape under RedHat 6.0 as generically
configured (I.E. with the GNOME session manager enabled
by default.)

	Start the Java console from the
		Communicator->Tools->Java Console
	menu.

Netscape dies with a bus error, but does NOT leave a core
dump.

This demonstrates that Netscape dies on ANY page that uses
java.

This occurs with 4.51 as installed in the usual 6.0,
also with 4.6 as distributed in the upgrade RPM,
as well as 4.61 (libc2 version) fetched from Netscape.com,
which RUNS JUST FINE under RedHat 5.2 (and fvwm instead of
enlightenment).

This bus error occurrs both with MOZILLA_HOME unset
(the default) and with MOZILLA_HOME set to
/usr/lib/netscape.

I think this is a RedHat issue more than a Netscape
issue, since the same netscape binaries do work just fine
under 5.2.

Am I getting bit by a libc incompatibility?

I am VERY surprised nobody else has reported so obvious
a bug.  A colleague with a similar machine and config to
mine has ALSO reproduced this problem.

I do not know if this problem affects other platforms
than the i386.

Comment 1 Bill Nottingham 1999-09-29 20:13:59 UTC
*** This bug has been marked as a duplicate of 2711 ***


Note You need to log in before you can comment on or make changes to this bug.