Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5439 - rpm -U doesn't work
Summary: rpm -U doesn't work
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 3277 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-29 19:41 UTC by ilh
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-29 20:26:27 UTC


Attachments (Terms of Use)

Description ilh 1999-09-29 19:41:50 UTC
I am running 6.0 with all updates (as of two days ago).  My
rpm is 3.0.2-6.0.

If I do "rpm -Uv A.rpm B.rpm", and A is already installed on
the system, I get the message "package A is already
installed", but B does not install.  This is exactly what I
would expect from "rpm -i", but not "-U" upgrade.

Shouldn't "rpm -U" install all new packages?

Comment 1 ilh 1999-09-29 19:54:59 UTC
I should point out that this bug does not exist with rpm-2.5.5-5.2 on
Red Hat 5.2.

Comment 2 Jeff Johnson 1999-09-29 20:26:59 UTC
This isn't a bug, it's a feature in rpm-3.0.x. All command line
packages are included in a transaction set that is installed as
a single unit. If any package fails to install, then the entire
package set fails to install.

Comment 3 maavl 1999-11-25 12:08:59 UTC
This duplicates bug 3277, see also bug 6182.

Comment 4 Jeff Johnson 2000-10-23 14:09:56 UTC
*** Bug 3277 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.