Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5420 - userdel crashes without a GID listing of the user in /etc/group
Summary: userdel crashes without a GID listing of the user in /etc/group
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils
Version: 6.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-28 19:23 UTC by dro
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-29 18:18:48 UTC


Attachments (Terms of Use)

Description dro 1999-09-28 19:23:14 UTC
Im guessing this is under shadow-utils, but who reall knows
:)

The problem is this:

userdel will segfault and dump core if you try to remove a
user that doesn't have a GID listing in /etc/group. I have
only experienced this problem on RH 6 systems, but I also
don't have access to previous releases.

I was able to test this on an old slackware machine, and it
was unaffected

Comment 1 David Lawrence 1999-09-29 18:18:59 UTC
This seems to be working in the lastest release of shadow-utils that
is available from our ftp site.

ftp://ftp.redhat.com/pub/rawhide/i386/RedHat/RPMS/shadow-utils-19990827-2.i386.rpm


Note You need to log in before you can comment on or make changes to this bug.