Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5412 - tcsh produces 'Cannot open /dev/port: Permission denied'
Summary: tcsh produces 'Cannot open /dev/port: Permission denied'
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL: -
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-28 08:51 UTC by bwess
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-05 20:42:06 UTC


Attachments (Terms of Use)

Description bwess 1999-09-28 08:51:32 UTC
This seems related to bug #3909.

I updated several machines from RH5.2 to 6.0 and built a
2.2.12 kernel. Now all of them show this error whenever a
tcsh is opened by a user (at all logins and even when e.g.
less calls lesspipe.sh to find out how to handle a file).
Stracing around I saw that /dev/port isn't even accessed by
the called program itself, the device seems to be accessed
somewhere else.
If the permissions are wrong (666, see 'man 4 port') the
'Permission denied' changes into a 'Operation not
permitted'...

Please mail me if you can't reproduce this bug.

TIA

Comment 1 Jeff Johnson 2000-01-10 20:55:59 UTC
You might want to check for a use of kbdrate from util-linux. There are
some fixes in util-linux for accessing /dev/port (and PAM console is involved).

Changing component to util-linux. Please change back to tcsh if that's where the
fix needs to be.

Comment 2 Bill Nottingham 2000-02-05 20:42:59 UTC
closed, lack of input.


Note You need to log in before you can comment on or make changes to this bug.