Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5409 - XFree86-3.3.5 XF86_SVGA broken
Summary: XFree86-3.3.5 XF86_SVGA broken
Keywords:
Status: CLOSED DUPLICATE of bug 6970
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-28 02:27 UTC by pierre
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-14 17:03:42 UTC


Attachments (Terms of Use)

Description pierre 1999-09-28 02:27:48 UTC
History:  I recently upgraded to XFree86-3.3.5 on my RH6.0
AMD K6-II Linux box using the rpms from the
ftp://ftp.redhat.com/updates site.  My motherboard is a TX
Pro-II with on board SiS 5597/5598 video and CMI8330 sound.
When I upgraded the XF86_SVGA server I found it to be broken
and all my X windows text disappeared, it appeared as
coloured solid blocks and the mouse pointer would regularly
turn into a solid 32x32 block.

Fix:  Not wanting to retrograde back to XFree86-3.3.3.1,
which had previously worked, I installed the SuSE XFCom_SiS
server from http://www.suse.de/XSuSE/XSuSE_E.html and
renamed it XF86_SVGA.  This fixed the problem and I was even
able to use my previous XF86Config file.

Comment 1 mcornick 1999-10-05 20:08:59 UTC
I'm seeing the same problem here with a system that has the SiS 5598
on board. Text appears as solid black boxes; some pixmaps appear as
random garbage.

Installing SuSE's XFCom_SiS fixed it for me, too. The XFCom_SiS readme
states "This driver supports the SiS 6326, 530, 540, 620, 630 and 300
chipsets (and the older ones that are already supported in
XFree86-3.3.5 as well, but with no changes whatsoever)." Did a patch
applied sometime between 3.3.3.1 and 3.3.5 break this?

I have the same problem with XFree86-SVGA-3.3.5-1.6.0 and
XFree86-SVGA-3.3.5-0.6.0 RPMs.

Comment 2 mcornick 1999-10-16 23:24:59 UTC
Hmm, it looks like this is a bug in XFree86 code, not Red Hat's doing.
I tried 3.3.5 under FreeBSD 3.3 on this same hardware, and the same
thing happened.

I filed a bug with the XFree86 project.

Comment 3 Preston Brown 2000-01-14 17:03:59 UTC
*** This bug has been marked as a duplicate of 6970 ***


Note You need to log in before you can comment on or make changes to this bug.