Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 54 - termcap problems
Summary: termcap problems
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libtermcap
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike Maher
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-12 17:14 UTC by cadams
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-15 18:51:54 UTC


Attachments (Terms of Use)

Description cadams 1998-11-12 17:14:38 UTC
The libtermcap doesn't properly handle the /etc/termcap file
in RH 5.2.  First, it doesn't handle more than one "tc="
attribute at all.  Also, it doesn't grok "%p" in the
attribute strings.

I will send two patches (one for each of these bugs) after I
file this bug report.  With these two bugs fixed, the
"vim-color" package is not needed (because then the termcap
version can do color just fine).

Comment 1 Derek Tattersall 1998-11-19 17:06:59 UTC
The accompanying patches are supposed to fix the color problem.

Comment 2 Preston Brown 1999-03-18 14:44:59 UTC
Mike I think you are handling termcap testing, can you take care of
these changes?  They all look sane to me, including removal of
vim-color...

Comment 3 Preston Brown 1999-03-25 22:19:59 UTC
our new termcap and terminfo work fine with regular vim in color on
both the console and in X under xterms, so vim-color has been removed.

Comment 4 cadams 1999-05-14 18:48:59 UTC
These bugs are still in the libtermcap package in RH 6.0.  The same
patches as before still are needed to fix the problems.  If I am on a
RH 6.0 Linux console and run vi, I don't get the colors (all I get is
some bold text).  The problem is that libtermcap doesn't handle the
"tc=" attribute, which includes another termcap entry.  The "linux"
entry has 3 tc attributes, which are not picked up correctly.

Comment 5 Jeff Johnson 1999-05-15 18:51:59 UTC
Patches applied. Thanks for persisting. The miscommunication appears
to be another confusion between the termcap based minimal /bin/vi
and the terminfo based featureful /usr/bin/vi.


Note You need to log in before you can comment on or make changes to this bug.