Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5382 - sndconfig can cause permanent system crash
Summary: sndconfig can cause permanent system crash
Keywords:
Status: CLOSED DUPLICATE of bug 5429
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sndconfig
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-26 22:44 UTC by Stephen John Smoogen
Modified: 2014-03-17 02:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-29 16:24:17 UTC


Attachments (Terms of Use)

Description Stephen John Smoogen 1999-09-26 22:44:19 UTC
If your system contains certain sound cards (Dell Inspiron
3500 ) you can end up with a locked system that can only be
edited from a rescue mode.

The problem is that sndconfig edits /etc/conf.modules before
it tests if your system has a working sound card. On
installing module it can crash the system. If you reboot you
cannot get around the modules being loaded even if you do
a linux single because of /etc/conf.modules syntax.

Suggested Fix:
a)  have sndconfig test modules via explicit insmod commands
and at end of run write /etc/conf.modules
b) have initscripts not load sound modules in single user
mode

Comment 1 Bill Nottingham 1999-09-26 22:57:59 UTC
FWIW, sndconfig does tell you it's writing a new
conf.modules. :)

Boot with "linux nomodules"; alternatively "linux init=/bin/bash".

Comment 2 Bill Nottingham 1999-09-29 16:24:59 UTC
*** This bug has been marked as a duplicate of 5429 ***


Note You need to log in before you can comment on or make changes to this bug.