Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5381 - gnome-terminal sometimes core dumps on SMP box
Summary: gnome-terminal sometimes core dumps on SMP box
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-26 20:40 UTC by Stephen John Smoogen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-17 21:47:04 UTC


Attachments (Terms of Use)

Description Stephen John Smoogen 1999-09-26 20:40:16 UTC
[root@test81 /root]# rpm -qf /usr/bin/gnome-terminal
gnome-core-1.0.39-10

Core was generated by `gnome-terminal --sm-config-prefix
/gnome-terminal-BCKBH5/ --sm-client-id 11cfaf'.
Program terminated with signal 6, Aborted.

(gdb) bt
#0  0x403f34e1 in __kill () from /lib/libc.so.6
#1  0x403f3156 in raise (sig=6) at
../sysdeps/posix/raise.c:27
#2  0x403f4868 in abort () at ../sysdeps/generic/abort.c:88
#3  0x40081df6 in gnome_segv_handle () from
/usr/lib/libgnomeui.so.32
#4  0x403f3408 in __restore ()
    at ../sysdeps/unix/sysv/linux/i386/sigaction.c:127
#5  0x403c48d8 in vt_draw_selection () from
/usr/lib/libzvt.so.2
#6  0x403ca579 in zvt_term_button_release () from
/usr/lib/libzvt.so.2
#7  0x401c1719 in gtk_marshal_BOOL__POINTER () from
/usr/lib/libgtk-1.2.so.0
#8  0x401ee45b in gtk_signal_real_emit () from
/usr/lib/libgtk-1.2.so.0
#9  0x401ec575 in gtk_signal_emit () from
/usr/lib/libgtk-1.2.so.0
#10 0x4022177c in gtk_widget_event () from
/usr/lib/libgtk-1.2.so.0
#11 0x401c1672 in gtk_propagate_event () from
/usr/lib/libgtk-1.2.so.0
#12 0x401c08ca in gtk_main_do_event () from
/usr/lib/libgtk-1.2.so.0
#13 0x4026b00b in gdk_event_dispatch () from
/usr/lib/libgdk-1.2.so.0
#14 0x403a8be6 in g_main_dispatch () from
/usr/lib/libglib-1.2.so.0
#15 0x403a91a1 in g_main_iterate () from
/usr/lib/libglib-1.2.so.0
#16 0x403a9341 in g_main_run () from
/usr/lib/libglib-1.2.so.0
#17 0x401c0209 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#18 0x8051ba4 in new_terminal ()
#19 0x8051bc6 in main ()
#20 0x403ed1eb in __libc_start_main (main=0x8051bb0 <main>,
argc=5,
    argv=0xbffffb94, init=0x804b64c <_init>, fini=0x8051bfc
<_fini>,
    rtld_fini=0x4000a610 <_dl_fini>, stack_end=0xbffffb8c)
    at ../sysdeps/generic/libc-start.c:90

How I triggered it:
-------------------
Opened a gnome-terminal
 rpm -Va &> somefile
Opened another gnome terminal

Had default window settings so focus did not transfer when I
began typing in other window... did a couple of ^U to try
and clear text. Worked in other terminal for a short while
and noticed nothing was happening in first terminal.
Switched focus to first terminal and tried a ^S^Q combo to
see if I had locked up earlier. Bingo gnome reports that
gnome-terminal had locked up.

Comment 1 Elliot Lee 1999-10-29 14:49:59 UTC
Can you provide some instructions for reproducing this? I can't seem
to do it using the "How I triggered it" ones.

Comment 2 Elliot Lee 1999-11-17 21:47:59 UTC
No instructions given on reproducing, so am closing.


Note You need to log in before you can comment on or make changes to this bug.