Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5364 - rpm 3.0.3-0.26|32: %defines are executed %inside non-matching %ifarch
Summary: rpm 3.0.3-0.26|32: %defines are executed %inside non-matching %ifarch
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm-build
Version: 1.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 6647 7584 7907 9415 13106 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-25 17:00 UTC by jbotha
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-29 21:46:54 UTC


Attachments (Terms of Use)

Description jbotha 1999-09-25 17:00:03 UTC
Discovered this one while rebuilding anonftp-2.8-2 on i386.
The spec file contains:
%ifarch i386 sparc armv41
%define LIBCSOVER 6
...
%endif

%ifarch alpha
%define LIBCSOVER 6.1
...
%endif

Well, after the first %ifarch, LIBCSOVER has value 6, but
after the second %ifarch it has value 6.1.  No other
commands seem to be executed inside the second %ifarch.

Comment 1 jbotha 1999-09-25 17:02:59 UTC
Oops, that should've been anonftp-2.8-1...

Comment 2 Jeff Johnson 1999-12-16 20:24:59 UTC
*** Bug 6647 has been marked as a duplicate of this bug. ****** Bug 7584 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Johnson 2000-01-31 16:18:59 UTC
*** Bug 7907 has been marked as a duplicate of this bug. ***

Comment 4 Jeff Johnson 2000-02-21 10:44:59 UTC
*** Bug 9415 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Johnson 2000-07-10 19:29:15 UTC
*** Bug 13106 has been marked as a duplicate of this bug. ***

Comment 6 Jeff Johnson 2001-02-21 19:21:35 UTC
Changing component.

Comment 7 Bill Nottingham 2005-09-29 21:46:54 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

For RPM issues, please try a current release such as Fedora Core 4; if bugs
persist, please open a new issue.


Note You need to log in before you can comment on or make changes to this bug.