Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5346 - problems with /cdrom exports
Summary: problems with /cdrom exports
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-24 11:02 UTC by srwalton
Modified: 2007-04-18 16:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-14 17:49:17 UTC


Attachments (Terms of Use)

Description srwalton 1999-09-24 11:02:03 UTC
On RedHat 5.2, I had set up a system with the CD-ROM mounted
as /cdrom, 'user' mount privileges enabled, and /cdrom NFS
exported to an HP-UX 10.20 system.  Worked fine.  At RedHat
6.0, this no longer works.  Specifically:

1.  The HP-UX system cannot see the contents of the CD, even
though both the RedHat and HP sides report a successful
mount.  In particular, "ls /net/redhatbox/cdrom" on the HP
returns no output (where /net/redhatbox/cdrom is the NFS
mount point on the NFS client).  No errors appear on the
console or in any logs on either system.

2.  After a successful umount of the CD from the NFS client,
the RedHat system will not allow an unmount of the physical
CD unless NFS is stopped first;  '/cdrom:  device busy' is
the error returned otherwise.  This is the case when the
only NFS mount is from a non-HP-UX system as well.

I can export any other file system from RedHat to the HP-UX
box without trouble.  I have tried knfsd-1.4.7 from the
Rawhide distribution but there was no change.  I have tried
/sbin/rpcdebug but it complains that /proc/net/rpc/debug
doesn't exist.

Comment 1 atris 2000-02-08 14:33:59 UTC
I also see such things on my RedHat 6.1.
When I mount _any_ filesystem, export them into NFS,
mount exported NFS shares, succesfully use them,
successfully unmount NFS shares, then I try to unmount
filesystem, ang got 'device busy'. After stopping and starting
NFS daemon I was able to unmount my filesystems. Simple restarting
NFS daemon does not have effect. I must stop and start nfsd again.

Comment 2 Cristian Gafton 2000-08-09 02:35:50 UTC
assigned to johnsonm

Comment 3 Stephen John Smoogen 2003-01-24 18:27:15 UTC
Is this problem still occuring in Red Hat Linux 7.3/8.0? I could not duplicate
the exact problem, but may not be following the same steps as yours. 

Comment 4 Jay Turner 2003-04-14 17:49:17 UTC
Closing this out as result of bit-rot.


Note You need to log in before you can comment on or make changes to this bug.