Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5309 - sound sndconfig can't identify MedisVision Pro Audio Studio 16
Summary: sound sndconfig can't identify MedisVision Pro Audio Studio 16
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sndconfig
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
: 5718 6811 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-22 16:46 UTC by svaduva
Modified: 2014-03-17 02:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-08 22:33:51 UTC


Attachments (Terms of Use)

Description svaduva 1999-09-22 16:46:25 UTC
I am using an old MedisVision Pro Audio Studio 16 sound
card with a SCSI port. The SCSI works just fine but I have
problems with the sound. Although it is said (Sound HOWTO)
that this card is supported, I can't get it to run in RH
6.0.

sndconfig reported no PnP or PCI sound cards
tried all card types and the only one working is AdLib (it
plays a MIDI sound)

the content of /etc/conf.modules is:

alias scsi_hostadapter pas16
.
.
.
alias sound adlib_card
pre-install sound insmod sound dmabuf=1
options adlib_card io-0x388

so far the only think correct is the I/O at 388h (there is
no jumper on the board for IRQs, and DMAs)
cat /dev/sndstat reports:

Config options: 0

Installed Drivers:

Audio devices:

Synth devices:
0: Yamaha OPL3

Midi devices:

Timers:

0: System clock

Mixers:

Any suggestion(s)?

Comment 1 Bill Nottingham 1999-09-22 16:57:59 UTC
What happens if you try the Pro Audio Spectrun driver?

Comment 2 svaduva 1999-09-22 19:03:59 UTC
If I select Pro Audio Spectrum/Studio 16, Logitech SoundMan 16 I get
a list of I/Os IRQs and DMAs (I/O 220, 230, 240; IRQ 3, 5, 7, 9; DMA
0,1,2,3)
Neither of them are available for jumper setup on the card (card has
jumpers for the address of the card - seams like a SCSI ID) and I am
set to default (388h).
Anyhow, I selected (after a few trials) from this list I/O 220h, IRQ
9, and DMA 0

Answer (from sndconfig) is /lib/modules/2.2.5-15/misc/pas2.o:
init_module: Device or resource busy
sound: Device or resource busy

now, the /etc/conf.modules contains:

alias scsi_hostadapter pas16
.
.
.
options adlib_card io=0x388
alias sound pas2=1
pre-install sound insmod sound dmabuf=1
options sb pas=1
options pas2 io=0x220 irq=9 dma=0 joystick=1

after this I tried /etc/rc.d/init.d/sound restart and it says:
error opening /dev/mixer: No such device sound

Comment 3 Bill Nottingham 1999-09-22 20:39:59 UTC
Try using a different IRQ (most likely 5 or 7), and DMA 1.

Comment 4 svaduva 1999-09-22 20:55:59 UTC
I omitted to tell you that the other day I tried ALL combinations:(
None works with Pro Audio Spectrun driver.

Comment 5 svaduva 1999-09-23 16:34:59 UTC
Maybe this will not add more fog in the sky!

I'm not positive the isapnp is running. I don't have a file
/etc/isapnp.conf

Comment 6 Bill Nottingham 1999-09-23 18:19:59 UTC
isapnp shouldn't be running; it's not a PnP card, AFAIK.

Do you have any error messages in /var/log/messages
from trying to load the module?

Comment 7 svaduva 1999-09-23 19:36:59 UTC
from /var/log/messages
.
.
.
sound: Starting sound configuration:
modprobe: can't locate module sound-slot-0
modprobe: can't locate module sound-service-0-0
sound: aumix: error opening /dev/mixer: No such device
sound: sound
rc: Starting sound succeeded
.
.
.
modprobe: can't locate module sound-slot-0
modprobe: can't locate module sound-service-0-3
modprobe: can't locate module sound-slot-0
modprobe: can't locate module sound-service-0-3
modprobe: can't locate module sound-slot-0
modprobe: can't locate module sound-service-0-3
modprobe: can't locate module sound-slot-0
modprobe: can't locate module sound-service-0-3
modprobe: can't locate module sound-slot-0
modprobe: can't locate module sound-service-0-3
modprobe: can't locate module sound-slot-0
modprobe: can't locate module sound-service-0-3
modprobe: can't locate module sound-slot-0
modprobe: can't locate module sound-service-0-3
modprobe: can't locate module sound-slot-0
modprobe: can't locate module sound-service-0-3
modprobe: can't locate module sound-slot-0
modprobe: can't locate module sound-service-0-3

Comment 8 Bill Nottingham 1999-09-23 19:43:59 UTC
Those aren't really useful ; trying
modprobe pas2 io=0x220 irq=5 dma=1
doesn't print any debugging messages in the system logs?

Comment 9 svaduva 1999-09-23 20:28:59 UTC
After
modprobe pas2 io=0x220 irq=5 dma=1

I get:
/lib/modules/2.2.2-15/misc/pas2.0: init_module: Device or resource
busy

I don't know how to get to the debugging messages.

Comment 10 Bill Nottingham 1999-09-23 20:38:59 UTC
Look in /var/log/messages - is there anything in there
besides the 'device or resource busy' that indicates
why it failed?

Comment 11 svaduva 1999-09-23 21:24:59 UTC
After I type
modprobe pas2 io=0x220 irq=5 dma=1
the only line added to /var/log/messages is
Pro Audio Spectrum driver Copyright ...

Comment 12 svaduva 1999-09-23 22:26:59 UTC
running
modprobe --debug pas2 io=0x220 irq=5 dma=1
doesn't add anything else to /var/log/messages other than:
kernel: Pro Audio ...

earlier in the file (at boot) it says:
sound: Starting sound configuration:modprobe: can't locate module
sound-slot-0
modprobe: can't locate module sound-service-0-0
sound: aumix: error opening /dev/mixer: No such devicesound: sound
rc: Starting sound succeeded
and then:
modprobe: can't locate module sound-slot-0
modprobe: can't locate module sound-service-0-3
for a few times.

Comment 13 Bill Nottingham 1999-11-01 18:57:59 UTC
What happens if you try:

modprobe pas2 io=0x388 irq=5 dma=1?

Comment 14 svaduva 1999-11-01 19:38:59 UTC
I hear a click. Good news.
if I change the /etc/conf.modules to:
options pas2 io=0x388 irq=5 dma=1 joystick=1
every time I play a sound I hear a squeaky noise.
What next?

Comment 15 Bill Nottingham 1999-11-01 19:40:59 UTC
Hmm... are there any error messages like 'DMA timed out'
in /var/log/messages after you try and play sounds?

Comment 16 svaduva 1999-11-01 20:39:59 UTC
None. No DMA errors and no entry in the log file.

Comment 17 Bill Nottingham 1999-11-01 20:48:59 UTC
Is the 'squeak' a fast version of the sound, the beginning
of the sound, or just random garbage?

Comment 18 svaduva 1999-11-01 21:10:59 UTC
It is more like garbage. It takes a different amount of time based on
what sound is played. I personally think that the time to play is
longer but I can't tell. BTW, how can I play a MIDI file?

Comment 19 Bill Nottingham 2000-02-08 22:33:59 UTC
*** Bug 5718 has been marked as a duplicate of this bug. ****** Bug 6811 has been marked as a duplicate of this bug. ***

Comment 20 Bill Nottingham 2002-01-23 05:25:08 UTC
This probably won't be fixed by us; at this point we don't have PAS16 hardware
to test with and debug against.


Note You need to log in before you can comment on or make changes to this bug.