Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5292 - lo not initializing on bootup
Summary: lo not initializing on bootup
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-22 01:48 UTC by kennethash
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-29 17:56:16 UTC


Attachments (Terms of Use)

Description kennethash 1999-09-22 01:48:57 UTC
I installed the following rpm's from your web site.

ampd-3.0beta5-8.i386.rpm
telnet-0.10-29.i386.rpm
xscreensaver-3.09-4.i386.rpm
net-tools-1.52-2.i386.rpm
wu-ftp-2.5.0-5.6.0.i386.rpm

Upon bootup lo is not initializing which caused nfsd and
other nfs related processes to fail. If I booted into single
user and config'd lo manually everything worked. I am
running RH 6.0 with the 2.2.5-22 kernel. I found the cause
of the problem. During the upgrade of one of these rpm's the
/etc/sysconfig/network-scripts/ifcfg-lo file was replaced or
overwritten. The new file contained only the line
BOOTPROTO=none and a new file ifcfg- as created. I modified
ifcfg-lo adding NETWORK, IPADDR, DEVICE, ONBOOT, BROADCAST,
NETMASK entries. This seems to have cleared the problem.
Please let me know if you can suggest a cause of this file
being overwritten. Thank-you.

Comment 1 David Lawrence 1999-09-29 17:56:59 UTC
From what I can tell none of the rpm's listed install that file or
even have internal scripts to modify it. I have been unable to
replicate the problem in our test lab. The only package that touches
that file is the initscripts package and it has ifcfg-lo marked as a
config file which means it should be backed up in the same directory
as ifcfg-lo.rpmsave if any changes were made to that file.


Note You need to log in before you can comment on or make changes to this bug.