Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 528 - symlink data in RPM for this package broken
Summary: symlink data in RPM for this package broken
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 950 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-19 00:20 UTC by Joe Harrington
Modified: 2015-03-27 19:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-01-12 15:41:26 UTC


Attachments (Terms of Use)

Description Joe Harrington 1998-12-19 00:20:21 UTC
rpm -v flags mode discrepancies on many symlinks.  They are
mode 755 or 644 in the package but get installed mode 777
(and it is impossible to change them to any other mode with
chmod).

ncurses-4.2-10
.M......   /usr/lib/libform.so.4
.M......   /usr/lib/libmenu.so.4
.M......   /usr/lib/libncurses.so.4
.M......   /usr/lib/libpanel.so.4

Comment 1 Derek Tattersall 1998-12-21 15:35:59 UTC
This bug, and the next several are really rpm anomalies, as info chmod
indicates that symlinks always have permissions of 777 and that when
one
attempts to chmod a symlink the underlying file's permissions are
changed.

Comment 2 Derek Tattersall 1998-12-21 15:36:59 UTC
see bug 528

Comment 3 Jeff Johnson 1999-01-12 15:41:59 UTC
Fixed in recent versions of rpm-2.5.x/rpm-2.90.x.

Comment 4 Jeff Johnson 1999-02-16 22:17:59 UTC
*** Bug 950 has been marked as a duplicate of this bug. ***

In some packages of the Apollo release, there are symbolic
links which RPM thinks should have mode lrwxr-xr-x (despite
the fact that *every* symlink *always* has mode lrwxrwxrwx).
See e.g. `/usr/bin/X11' in package `filesystem'.

Fix:
In build/files.c:add_file(), don't reset the file's mode if
it is a symlink (i.e., if S_ISLNK(p->statbuf)).  Also, in
lib/verify.c:rpmVerifyFile(), don't verify the file's mode
it it is a symlink.


------- Additional Comments From ayn2@cornell.edu  01/25/99 22:43 -------
This is a duplicate of #528, #533 and #535

Comment 5 openshift-github-bot 2015-03-27 19:07:49 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/0f50aa4f547e63ca059d45cc3be0d9a1b621efa9
Issue #333, #528 - add number to builds


Note You need to log in before you can comment on or make changes to this bug.