Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5249 - TeX/kpathsea takes forever to verify that fonts exist
Summary: TeX/kpathsea takes forever to verify that fonts exist
Keywords:
Status: CLOSED DUPLICATE of bug 5326
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-20 15:34 UTC by hughett
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-15 22:56:01 UTC


Attachments (Terms of Use)

Description hughett 1999-09-20 15:34:15 UTC
When I run TeX on a small file, it takes about 10 seconds
to verify that all the fonts exist, followed by about a
second to actually compile the file.  The previous version
did everything in a second or two.

Sample:

[hughett@chaplin ncf99]$ tex desc
This is TeX, Version 3.14159 (Web2C 7.3)
(desc.tex (/home/hughett/tex/newfonts.texkpathsea: Running
mktextfm  cmr12
mktextfm: /var/lib/texmf/tfm/public/cm/cmr12.tfm already
exists.
kpathsea: Running mktextfm  cmmi12
mktextfm: /var/lib/texmf/tfm/public/cm/cmmi12.tfm already
exists.
kpathsea: Running mktextfm  cmsy10
mktextfm: /var/lib/texmf/tfm/public/cm/cmsy10.tfm already
exists.
kpathsea: Running mktextfm  cmex10
mktextfm: /var/lib/texmf/tfm/public/cm/cmex10.tfm already
exists.
kpathsea: Running mktextfm  cmbx12
mktextfm: /var/lib/texmf/tfm/public/cm/cmbx12.tfm already
exists.
kpathsea: Running mktextfm  cmti12
mktextfm: /var/lib/texmf/tfm/public/cm/cmti12.tfm already
exists.
kpathsea: Running mktextfm  cmtt12
mktextfm: /var/lib/texmf/tfm/public/cm/cmtt12.tfm already
exists.
) (/home/hughett/tex/btxmac.tex)kpathsea: Running mktextfm
cmss12
mktextfm: /var/lib/texmf/tfm/public/cm/cmss12.tfm already
exists.
kpathsea: Running mktextfm  msbm10
mktextfm: /var/lib/texmf/tfm/ams/symbols/msbm10.tfm already
exists.
kpathsea: Running mktextfm  msbm10
mktextfm: /var/lib/texmf/tfm/ams/symbols/msbm10.tfm already
exists.

[1] [2] [3] (desc.aux) [1] )
Output written on desc.dvi (4 pages, 8672 bytes).
Transcript written on desc.log.

The log file contains nothing remarkable.

Paul Hughett

Comment 1 Jeff Johnson 2000-01-15 22:56:59 UTC
*** This bug has been marked as a duplicate of 5326 ***

Comment 2 hughett 2000-02-01 15:52:59 UTC
I made the modification suggested in bug report #5326 but this had no effect
on the problem.  After some experimentation I found that removing the line
     export TEXFONTS=.:$HOME/tex/fonts:/var/lib/texmf/
did fix the problem, whether or not the modification from #5326 was installed.
I have been using TeX for going on ten years now, and set up the environment
variables several years ago; it appears that the newest kpathsea configuration
is incompatible with the old environment variables.


Note You need to log in before you can comment on or make changes to this bug.