Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 523631 - Files in /etc/rhn/default should not be %config(noreplace)
Summary: Files in /etc/rhn/default should not be %config(noreplace)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades
Version: 530
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Michael Mráka
URL:
Whiteboard: Fixed in the 5.4.0 Release - GA'd 201...
Depends On:
Blocks: sat540-canfix
TreeView+ depends on / blocked
 
Reported: 2009-09-16 09:16 UTC by Miroslav Suchý
Modified: 2010-10-28 15:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-28 15:03:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Miroslav Suchý 2009-09-16 09:16:12 UTC
Description of problem:
If user edit file in /etc/rhn/default/something and then he upgrade satellite, the new file is saved as /etc/rhn/default/something.rpmnew and since we do not tell user to check for rpmnew files he get with old default. Which is fatal for e.g. taskomatic.

Version-Release number of selected component (if applicable):
spacewalk-java-config-0.5.44-41.el5sat

How reproducible:
done once

Steps to Reproduce:
1. have sat520
2. edit /etc/rhn/default/rhn_taskomatic.conf (just add some comment there)
3. upgrade to sat530
  
Actual results:
1. you will get /etc/rhn/default/rhn_taskomatic.conf.rpmnew
2. taskomatic will fail to run since it refers to 5.2 java classes

Expected results:
1. you will not get /etc/rhn/default/rhn_taskomatic.conf.rpmnew
2. taskomatic will run without problem

Comment 1 Miroslav Suchý 2009-09-16 09:26:00 UTC
Commited to Spacewalk.git as c1bb92a95c9be8ca806259386a47e3ff6f9068d3

Comment 2 Miroslav Suchý 2010-08-05 11:44:44 UTC
Actually it is commit 19039767e10699dd4f01d0379c9041b744d4618b

Comment 3 Michael Mráka 2010-10-06 08:05:12 UTC
FAILS_QA:

There are files without %config(noreplace) left:
osad.spec:%config %{_sysconfdir}/rhn/default/rhn_osa-dispatcher.conf
java/spacewalk-java.spec:%config %{_sysconfdir}/rhn/default/rhn_hibernate.conf
java/spacewalk-java.spec:%config %{_sysconfdir}/rhn/default/rhn_taskomatic_daemon.conf
java/spacewalk-java.spec:%config %{_sysconfdir}/rhn/default/rhn_taskomatic.conf
java/spacewalk-java.spec:%config %{_sysconfdir}/rhn/default/rhn_org_quartz.conf
satellite-branding/satellite-branding.spec:%{_sysconfdir}/rhn/default/rhn_docs.conf
web/spacewalk-web.spec:%attr(640,root,apache) %config %{_sysconfdir}/rhn/default/rhn_web.conf
web/spacewalk-web.spec:%attr(640,root,apache) %config %{_sysconfdir}/rhn/default/rhn_dobby.conf
web/spacewalk-web.spec:%attr(640,root,apache) %config %{_sysconfdir}/rhn/default/rhn_web.conf

Comment 4 Miroslav Suchý 2010-10-06 11:42:13 UTC
We do *not* want to have %config(noreplace). I.e. instead of %config(noreplace) we want pure  %config. Those which was %config only is ok.

$ git grep '/default/' |grep '%config' | grep '(noreplace)'
give me no output. 

Flipping back to ON_QA

Comment 5 Michael Mráka 2010-10-06 12:08:36 UTC
Oops, files *should not* have %config(noreplace) so it's alright.

Verified  for
[root@ibm-x3650-01 ~]# rpm -qf /etc/rhn/default/* | sort -u 
osa-dispatcher-5.9.38-1.el5sat
satellite-branding-5.4.0.8-1.el5sat
spacewalk-backend-1.2.13-9.el5sat
spacewalk-backend-app-1.2.13-9.el5sat
spacewalk-backend-applet-1.2.13-9.el5sat
spacewalk-backend-config-files-1.2.13-9.el5sat
spacewalk-backend-config-files-tool-1.2.13-9.el5sat
spacewalk-backend-iss-export-1.2.13-9.el5sat
spacewalk-backend-package-push-server-1.2.13-9.el5sat
spacewalk-backend-server-1.2.13-9.el5sat
spacewalk-backend-tools-1.2.13-9.el5sat
spacewalk-backend-upload-server-1.2.13-9.el5sat
spacewalk-backend-xmlrpc-1.2.13-9.el5sat
spacewalk-backend-xp-1.2.13-9.el5sat
spacewalk-base-minimal-1.2.7-4.el5sat
spacewalk-dobby-1.2.7-4.el5sat
spacewalk-java-config-1.2.39-26.el5sat
spacewalk-pxt-1.2.7-4.el5sat

Comment 6 Clifford Perry 2010-10-28 15:03:26 UTC
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford


Note You need to log in before you can comment on or make changes to this bug.