Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 522 - wrong logrotate.conf
Summary: wrong logrotate.conf
Keywords:
Status: CLOSED DUPLICATE of bug 372
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: logrotate
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-18 23:16 UTC by borgia
Modified: 2012-04-02 13:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-31 20:51:25 UTC


Attachments (Terms of Use)

Description borgia 1998-12-18 23:16:41 UTC
logrotate.conf doesn't handle lastlog, even tough it's
supposed to, and does not compress logs by default
[version 2.6-3]

Comment 1 David Lawrence 1998-12-23 15:56:59 UTC
This report reduces to a policy question, (why doesn't logrotate
rotate lastlog) and a product improvement suggestion, (why doesn't
logrotate compress back level logs).

Comment 2 borgia 1998-12-26 23:02:59 UTC
No, it is not a policy question! Please read the comments in your own
products:

From /etc/logrotate.conf as shipped in 5.2:
-cut-cut-
# no packages own lastlog or wtmp -- we'll rotate them here
/var/log/wtmp {
    monthly
    rotate 1
}

# system-specific logs may be configured here

Doh: the script says it should handle lastlog, but doesn't...

Comment 3 Aleksey Nogin 1998-12-26 23:38:59 UTC
This bug report is a duplicate of #372

Comment 4 Jeff Johnson 1998-12-31 20:51:59 UTC
*** This bug has been marked as a duplicate of 372 ***


Note You need to log in before you can comment on or make changes to this bug.