Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5208 - Latest rpm broke the screensaver
Summary: Latest rpm broke the screensaver
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 6813 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-18 18:13 UTC by margarita
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-29 18:29:42 UTC


Attachments (Terms of Use)

Description margarita 1999-09-18 18:13:00 UTC
My screensaver was working OK. but was broken by the last
rpm. I am assuming that it was the xscreensaver-3.09-4.i386.
rpm or the screen-3.7.6-9.i386.rpm. It was installed on
Friday Evening September 17 1999. Renewed settings in
the Desktop settings don't affect anything.

Milleum MGA card
Viewsonic P810, 21 inch monitor.

Comment 1 Bill Nottingham 1999-09-18 18:43:59 UTC
What errors are you getting?

Comment 2 margarita 1999-09-18 23:00:59 UTC
No errors are reported. The screen does go blank after a while but
will not display the selected saver image from the desktop. The
worst part of this error is that I selected password protection and
it gets me back without any password. There is probably cosmetic
error in the desktop selectio. When the OK button is selected the
right hand area of the GUI goes blank.

When I say no errors - no error is displayed or found in
/var/log/messages

Hope this helps

Comment 3 Bill Nottingham 1999-09-19 18:35:59 UTC
Are you attempting to run it as root? The screensaver
won't work for root...

Comment 4 Michael K. Johnson 1999-09-27 18:47:59 UTC
We'll assume you were trying to run the screensaver as root.  If
this was not the case, please re-open this bug report.  Thanks!

------- Additional Comments From   10/07/99 01:33 -------
I was running as root. The screensaver image failes to appear but
otherwise works. root gets a blank screen instead of the selected
image.

Comment 5 margarita 1999-10-25 21:56:59 UTC
Something is wrong here. The screensaver works just like it was
before it was "broke". The only difference is that the image
selector was blank. Otherwise the screensaver was OK.

Either way it's a bug. If it is not supposed to run as root then it
should not run. It does run, ust without the screensaver image.

Comment 6 Bill Nottingham 1999-10-29 18:29:59 UTC
The screen going blank is a function of the kernel.
The xscreensaver not running as root was part of a security
fix; it will not be changed back.

Comment 7 Bill Nottingham 1999-11-08 15:56:59 UTC
*** Bug 6813 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.