Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5203 - Illegal instruction in in endservent ()
Summary: Illegal instruction in in endservent ()
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libc
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-18 09:48 UTC by John Newbigin
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-18 18:45:53 UTC


Attachments (Terms of Use)

Description John Newbigin 1999-09-18 09:48:50 UTC
nslookup and other related tools (host, named) either lockup
(require kill -9) or core dump with Illegal instruction

Output of gdb /usr/bin/nslookup core

GNU gdb 4.17.0.11 with Linux support
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public
License, and you are
welcome to change it and/or distribute copies of it under
certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show
warranty" for details.
This GDB was configured as "i386-redhat-linux"...(no
debugging symbols found)...
Core was generated by `nslookup'.
Program terminated with signal 4, Illegal instruction.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /lib/ld-linux.so.2...done.
#0  0x8059c47 in endservent ()
(gdb)



I installed RedHat on a pentium, but when copied to am AMD
386, it causes problems.  I think the problem is libc
related, somewhere in name resolution.

The CPU does suffer from the popd bug.. here is dmesg

Linux version 2.2.5-15 (root@porky.devel.redhat.com) (gcc
version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)
) #1 Mon Apr 19 21:39:28 EDT 1999
Console: colour VGA+ 80x25
Calibrating delay loop... 7.94 BogoMIPS
Memory: 14648k/16640k available (1060k kernel code, 412k
reserved, 460k data, 60k init)
Checking if this processor honours the WP bit even in
supervisor mode... No.
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: 386
Checking 'hlt' instruction... OK.
Checking for popad bug... Buggy.
....

Comment 1 John Newbigin 1999-09-18 10:15:59 UTC
The asm command which appears to cause the problem is the
bswap %edi

Comment 2 Bill Nottingham 1999-09-18 18:45:59 UTC
Yup. If you grab the latest bind-utils from Raw Hide it should
be fixed. The compiler was outputting 486+ instructions when it
shouldn't have.


Note You need to log in before you can comment on or make changes to this bug.