Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 511 - XFree86-xfs-3.3.3-1: xfs coredumps at first request.
Summary: XFree86-xfs-3.3.3-1: xfs coredumps at first request.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 5.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
: 849 908 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-17 22:34 UTC by Aleksey Nogin
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-01-18 22:02:52 UTC


Attachments (Terms of Use)

Description Aleksey Nogin 1998-12-17 22:34:34 UTC
Hi,

I tried to upgrade XFree86 with the latest updates from
updates.redhat.com and I have a problem - xfs coredumps as
soon as X server tries to access it. When I downgraded back
to 3.3.2.3-18 (leaving 3.3.3-1 libs and server), everything
returned back to normal.

My configuration: RH 5.1 + updates, glibc-2.0.7-19, Kernel
2.1.130 (SMP).

Here is the tail of the strace output (showing reading of
the last two font directories on startup and everything
after that):

open("/usr/X11R6/lib/X11/fonts/cyrillic/100dpi/fonts.dir",
O_RDONLY) = 5
fstat(5, {st_mode=0, st_size=0, ...})   = 0
fstat(5, {st_mode=0, st_size=0, ...})   = 0
mmap(0, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x400cb000
read(5, "60\ncrox6t.pcf.gz -cronyx-times-"..., 4096) = 4096
brk(0x810d000)                          = 0x810d000
brk(0x810e000)                          = 0x810e000
brk(0x810f000)                          = 0x810f000
brk(0x8110000)                          = 0x8110000
read(5, "gz -cronyx-times-bold-r-normal--"..., 4096) = 351
brk(0x8111000)                          = 0x8111000
read(5, "", 4096)                       = 0
read(5, "", 4096)                       = 0
close(5)                                = 0
munmap(0x400cb000, 4096)                = 0
open("/usr/X11R6/lib/X11/fonts/cyrillic/100dpi/fonts.alias",
O_RDONLY) = -1 ENOENT (No such file or directory)
brk(0x8113000)                          = 0x8113000
open("/usr/u/nuprl/fonts/bdf/fonts.dir", O_RDONLY) = 5
fstat(5, {st_mode=0, st_size=0, ...})   = 0
fstat(5, {st_mode=0, st_size=0, ...})   = 0
mmap(0, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x400cb000
read(5, "5\nnuprl-20.pcf nuprl-20\nnuprl-"..., 4096) = 100
read(5, "", 4096)                       = 0
read(5, "", 4096)                       = 0
close(5)                                = 0
munmap(0x400cb000, 4096)                = 0
open("/usr/u/nuprl/fonts/bdf/fonts.alias", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/var/log/xfs-errors.log", O_WRONLY|O_CREAT|O_TRUNC,
0666) = 5
dup2(5, 2)                              = 2
close(5)                                = 0
gettimeofday({913930856, 761814}, NULL) = 0
select(128, [3 4], NULL, NULL, {599, 740000} <unfinished
...>
--- SIGCONT (Continued) ---
<... select resumed> )                  = -1 ENOSYS
(Function not implemented)
gettimeofday({913930886, 168388}, NULL) = 0
accept(3, {sin_family=AF_INET, sin_port=htons(3227),
sin_addr=inet_addr("128.84.248.55")}, [16]) = 5
setsockopt(5, IPPROTO_TCP1, [1], 4)     = 0
getsockname(5, {sin_family=AF_INET, sin_port=htons(7100),
sin_addr=inet_addr("128.84.248.55")}, [16]) = 0
getpeername(5, {sin_family=AF_INET, sin_port=htons(3227),
sin_addr=inet_addr("128.84.248.55")}, [16]) = 0
fcntl(5, F_SETFL, O_RDONLY|O_NONBLOCK)  = 0
gettimeofday({913930886, 169834}, NULL) = 0
gettimeofday({913930886, 170023}, NULL) = 0
select(128, [3 4 5], NULL, NULL, {570, 331000}) = 1 (in [5],
left {570, 340000})
gettimeofday({913930886, 170791}, NULL) = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++

Comment 1 David Lawrence 1998-12-17 22:41:59 UTC
This has been assigned to a developer for further review.

Comment 2 Aleksey Nogin 1998-12-17 22:45:59 UTC
I forgot to add: bug is 100% reproducable. I run startx (with xfs
being the only item in my FontPath), it tries to connect to xfs and
resolve "fixed" and xfs immediatelly crashes...

Comment 3 Preston Brown 1998-12-17 23:15:59 UTC
Please make sure that the path in your xfs.conf is correct.  If there
are any directories listed in that file that are not present, xfs
coredumps.

Comment 4 Aleksey Nogin 1998-12-17 23:27:59 UTC
When I had unexisting directories in the config file, xfs was politely
telling me about that (in xfs-errors) and exiting, not dumping core. I
just double-checked - all directories do exist. If you want, I can
send you the rest of the strace log where xfs succesfully reads all
font.dir files.

Comment 5 Patrick J. LoPresti 1998-12-18 21:22:59 UTC
I can confirm that this bug exists.  The fs/config file shipped with
XFree86-3.3.3 refers to directories which do not exist, but xfs merely
complains politely about those.
When you fix the path in fs/config, xfs crashes upon receiving its
first request.  Downgrading to 3.3.2.3 fixes the problem.

Comment 6 Jeff Johnson 1999-01-17 21:07:59 UTC
*** Bug 511 has been marked as a duplicate of this bug. ***

Running RedHat 5.1, upgraded to the December XFree86
updates including XFree86-xfs-3.3.3-1.i386.rpm.  Now if
I try to use xfs, it segfaults as X tries to start up,
making X die shortly afterward.  strace on xfs revealed
nothing useful.  Since I'm running kernel 2.2.0pre7, I
verified that it also had problems on 2.1.130, which it
does.  I'm using the SVGA server with an S3 Virge on a
Cyrix 6x86/166+.  To work around the problem, I have
stopped using the font server, but I'd like to be able
to use it.



------- Additional Comments From ayn2@cornell.edu  01/16/99 21:55 -------
This is a duplicate of #511

Comment 7 Preston Brown 1999-01-18 22:02:59 UTC
this is fixed in a forthcoming errata release of XFree86 3.3.3.1.

Comment 8 Jeff Johnson 1999-01-21 16:12:59 UTC
*** Bug 908 has been marked as a duplicate of this bug. ***

New font server from XFree86-xfs-3.3.3-1 crashes and
coredumps when connection to it is attempted.


Note You need to log in before you can comment on or make changes to this bug.