Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5092 - top gives incorrect %CPU information on SMP machines
Summary: top gives incorrect %CPU information on SMP machines
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: procps
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-12 18:59 UTC by Jeremy Katz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-04 21:38:31 UTC


Attachments (Terms of Use)

Description Jeremy Katz 1999-09-12 18:59:10 UTC
With procps-2.0.3-1 as included in Lorax 6.0.55, top's
behavior has changed such that %CPU gives the share of CPU
time of one processor since the last screen updated.

From man top(1)
%CPU The task's share of the CPU time since the last
screen update, expressed as a percentage of total CPU time.

I believe that this is caused by the change in determination
of HZ in proc/sysinfo.c

Comment 1 Jeff Johnson 1999-09-12 22:42:59 UTC
This should be fixed in the Raw Hide procps-2.0.3-1. Please reopen
this bug if not.

Comment 2 Jeff Johnson 1999-09-12 22:44:59 UTC
Whoops, this is still a problem in procps-2.0.3-1.

Comment 3 Michael K. Johnson 1999-09-20 00:44:59 UTC
The bug is in the man page.  People report this as a bug whichever
way it works...

Comment 4 Jeremy Katz 1999-10-03 02:20:59 UTC
The man page describes the behavior exhibited by top in
procps-2.0.4-2.  As far as I'm concerned, this bug can be closed.

Comment 5 Michael K. Johnson 1999-10-04 21:38:59 UTC
Thanks!


Note You need to log in before you can comment on or make changes to this bug.