Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5085 - glibc-2.1.2-7 (Lorax): deadlock with pthread-application
Summary: glibc-2.1.2-7 (Lorax): deadlock with pthread-application
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL: colorfullife.com/manfreds/lorax.tar.gz
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-12 08:20 UTC by Manfred Spraul
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-05 02:44:44 UTC


Attachments (Terms of Use)

Description Manfred Spraul 1999-09-12 08:20:55 UTC
stunnel-3.4a hangs. The application runs without any
problems on Rh 6.0 (Hedwig)
I could trace the problem to pthread (i.e. disabling pthread
makes the program usable).

Note: I'm not the maintainer of stunnel.
you can download it from
"mike.daewoo.com.pl/computer/stunnel"

Comment 1 Manfred Spraul 1999-09-13 11:27:59 UTC
It seems to be a linker problem:
I've written a sample program (~ 50 lines).
(colorfullife.com/manfreds/lorax.tar.gz)
The program hangs before "main()" is called.
It seems to be a linker problem.

Note that I could reproduce the problem only on one out of 3
computers.
This computer was initially installed as RH 5.2, later upgraded to RH
5.9, RH 6.0 and now RH 6.0.50.

Comment 2 Manfred Spraul 1999-09-17 13:06:59 UTC
Please ignore this bug report.
The problems were caused by a broken symlink to
"/lib/libpthread.so.0".

Comment 3 Cristian Gafton 2000-01-05 02:44:59 UTC
closed at the user's request


Note You need to log in before you can comment on or make changes to this bug.