Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5082 - mv broken by fileutils-4.0-5
Summary: mv broken by fileutils-4.0-5
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: fileutils
Version: 1.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 5121 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-12 05:17 UTC by Jeremy Katz
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-13 04:11:35 UTC


Attachments (Terms of Use)

Description Jeremy Katz 1999-09-12 05:17:31 UTC
mv is broken in fileutils-4.0-5.  If destination file does not exist, the move fails due to fail==0 and not checking if errno was just ENOENT.
Patch and updated SRPM mailed to lorax-list and cc'd to Christian Gafton (who made the change).

Comment 1 Bill Nottingham 1999-09-13 04:11:59 UTC
should be fixed in 4.0-6.

Comment 2 Bill Nottingham 1999-09-14 15:04:59 UTC
*** Bug 5121 has been marked as a duplicate of this bug. ***

mv is broken


Note You need to log in before you can comment on or make changes to this bug.