Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5062 - Scripting in /etc/profile.d/kde.csh is incorrect
Summary: Scripting in /etc/profile.d/kde.csh is incorrect
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesupport
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-11 01:46 UTC by mrovner
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-24 19:55:17 UTC


Attachments (Terms of Use)

Description mrovner 1999-09-11 01:46:32 UTC
Script has sh code where csh code should be in two places

The lines are:

kdepath="${KDEDIR}/bin"
if ( echo ${PATH} | grep -q ${kdepath} ) then


They should read:

set kdepath="${KDEDIR}/bin"
if ( `echo ${PATH} | grep -q ${kdepath}` ) then

The problem is that csh doesn't take the "variable=value"
that sh does, and if you leave out the grave accents,
csh, or more precisely tcsh, interprets the | as an
arithmetical operator and fails.

With both these changes, the script seems to function
correctly.  Without it, it causes and error and stops
login script processing, but not login itself.

Comment 1 Preston Brown 1999-09-24 19:55:59 UTC
fixed for next release.


Note You need to log in before you can comment on or make changes to this bug.