Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5053 - bus error after upgrade to XFree86 3.3.5
Summary: bus error after upgrade to XFree86 3.3.5
Keywords:
Status: CLOSED DUPLICATE of bug 6409
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netscape
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 5899 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-10 19:28 UTC by morgan
Modified: 2008-05-01 15:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-02 03:12:44 UTC


Attachments (Terms of Use)

Description morgan 1999-09-10 19:28:31 UTC
Background: Redhat 5.2, fully upgraded with latest packages
according to errata page.  Using roaming profiles with
netscape.

After upgrading to the XFree86 3.3.5 packages, netscape
crashes with a bus error after I enter my profile password
and click ok.  The bus error occurs before any of the
windows pop up telling me it is downloading my profile.

If I remove my ~/.netscape directory, netscape loads fine.
I tell it to use my roaming profile, quit netscape, and I
get a bus error again after I start netscape and enter my
profile password.

Comment 1 Michael K. Johnson 1999-09-19 23:38:59 UTC
Try upgrading netscape?  Since we don't have the source code to
netscape, there's not much we can do about it...  Sorry.  :-(

Comment 2 morgan 1999-09-20 15:51:59 UTC
I figured out, after downloading a half-dozen different copies of
netscape, that the libc5 based version works fine.  If I use any
version compiled against glibc... bus error!

Comment 3 Laurent CREPET 1999-10-25 07:46:59 UTC
Using netscape communicator 4.70 and 4.61 (from Netscape, or from
RedHat), I got bus error (randomly) when I close a window.

Comment 4 Bill Nottingham 1999-11-01 18:55:59 UTC
*** Bug 5899 has been marked as a duplicate of this bug. ***

Since I updated to XFree86 3.3.5-1.5 the login dialog in
netscape (I tryed 4.61 and 4.7 and both fail) is no longer
working: When I want do download a page which is password
protected the login dialog appears but when I press Enter
after typing in user-name and passord netscape crashes with
a bus error. This happens even if I supply the wrong
password.
I have RH5.2 and kernel 2.0.36 and I have installed all
relevant Erratas. I installed netscape 4.7 from SRPM and
4.61 from the binary rpms and both crash in this situation.

------- Additional Comments From   10/28/99 15:16 -------
I can confirm this problem.
netscape-navigator-4.7-1
XFree86-3.3.3.1-22
libc-5.3.12-29
Happens with earlier versions of netscape as well. It crashes
sometimes, sometimes it does not. But its always while accessing
password protected web pages. Really annoying.

Comment 5 jdalbec 1999-11-27 20:00:59 UTC
I got bus errors every time I closed a window using:
netscape-common-4.7-0.i386.rpm
netscape-communicator-4.7-0.i386.rpm
I installed communicator-v47-us.x86-unknown-linuxglibc2.0.tar.gz
and the errors went away (so far).
I haven't tried password-protected pages yet.

Comment 6 Bill Nottingham 2000-02-02 03:12:59 UTC
*** This bug has been marked as a duplicate of 6409 ***


Note You need to log in before you can comment on or make changes to this bug.