Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5049 - $config_file is not loaded into environment in script correctly
Summary: $config_file is not loaded into environment in script correctly
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhs-printfilters
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-10 16:26 UTC by kevin
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-10 17:05:30 UTC


Attachments (Terms of Use)

Description kevin 1999-09-10 16:26:47 UTC
the file:
/usr/lib/rhs/rhs-printfilters/smbprint

has a line that reads:
eval `cat $config_file`

it should read:
eval "`cat $config_file`"

in order to load the environment variables from
$config_file into the 'smbprint' script.

I have not checked where else this error occurs.

Kevin

Comment 1 Bill Nottingham 1999-09-10 17:05:59 UTC
I can't reproduce this; this works
fine here without the quotes.


Note You need to log in before you can comment on or make changes to this bug.