Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5034 - cannot locate rpm database on seperate partition during upgrade
Summary: cannot locate rpm database on seperate partition during upgrade
Keywords:
Status: CLOSED DUPLICATE of bug 13071
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brock Organ
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-09 23:05 UTC by tgke
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-10-06 16:26:45 UTC


Attachments (Terms of Use)

Description tgke 1999-09-09 23:05:21 UTC
Hello,

Some time ago, I upgraded my system from RedHat 5.1 to 6.0,
and I
experienced some troubles because of my rather "unusual"
partition
settings. Since I just read you are working on a new
release, I describe
you the problem and hope it will be taken care of to make
the new RedHat
upgrade even a bit better.

The problem was that the update script didn't find the RPM
database
located somewhere in /var. It didn't find it because /var
was just a
symlink to another directory on a seperate partition, which
isn't
mounted by the upgrade script. It took some time before I
understood
what was going on, afterwards I just moved the real /var
directory to my
root partition and moved it back to the seperate partition
after the
upgrade process.

I suggest you would at least document this situation, or
better, create
an option to mount the needed partition during the upgrade.

A last note: I believe the upgrade script complained about
the /tmp
directory as well - also a symlink - but this problem wasn't
fatal for
the upgrade itself.

Kind greetings,

Tung

<tg@skynet.be>

Comment 1 Brock Organ 2000-06-13 16:37:28 UTC
thanks for your report, tung!  Have you experienced the same problems with 6.2?

Comment 2 Brock Organ 2000-06-28 18:11:03 UTC
The current internal release (Winston, beta2) more gracefully brings up an RPM
db dialog error when this situation occurs: 'Rebuild of RPM database failed'

We will add your request for even better handling of this situation to our
feature request list ... thank you for your report!

Comment 3 Michael Fulbright 2000-10-04 18:23:30 UTC
Related to bug 18092.

Comment 4 Michael Fulbright 2000-10-06 16:26:40 UTC

*** This bug has been marked as a duplicate of 13071 ***


Note You need to log in before you can comment on or make changes to this bug.