Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5010 - /home/samba is a bad location in home automount environments
Summary: /home/samba is a bad location in home automount environments
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
: 5011 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-09 05:08 UTC by George Karabin
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-09 13:09:57 UTC


Attachments (Terms of Use)

Description George Karabin 1999-09-09 05:08:42 UTC
I recently started switching my companies Linux boxes to use
the company's home directory server. Home directories are
automounted via a map file exported by the NIS server.

The thing is, /home is an automounted directory (via NFS).
It seems to be a bad thing to install to /home/samba, since
you cannot have unique /home/samba directories for all of
the NIS clients on the network. While NIS home directories
could just as easily be automounted somewhere else, like
/nishome, most other unixes only install "real" user
directories to /home.

The net result is, I think Red Hat should make the
/home/samba directory elsewhere, along with any other such
directories (see my bug filed against apache).

Comment 1 Jeff Johnson 1999-09-09 13:01:59 UTC
*** Bug 5011 has been marked as a duplicate of this bug. ***

I recently started switching my companies Linux boxes to use
the company's home directory server. Home directories are
automounted via a map file exported by the NIS server.

The thing is, /home is an automounted directory (via NFS).
It seems to be a bad thing to install to /home/httpd, since
you cannot have unique /home/httpd directories for all of
the NIS clients on the network. While NIS home directories
could just as easily be automounted somewhere else, like
/nishome, most other unixes only install "real" user
directories to /home.

The net result is, I think Red Hat should make the
/home/httpd directory elsewhere, along with any other such
directories (see my bug filed against samba).

Comment 2 Jeff Johnson 1999-09-09 13:09:59 UTC
There's now way to change the location of these directories without
(possibly) finding them on an NFS share again.

You have two choices:

1) Add
	%_netsharedpath	/home
to /etc/rpm/macros (the value is a colon seperated path) and reinstall
the packages. No files will be installed in /home -- it's up
to you to populate those locations.

2) Change your mounting scheme to permit /home to reside on local
storage and mount existing NFS shares is something like
	/home/server_name_here


Note You need to log in before you can comment on or make changes to this bug.