Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 497177 - pulseaudio --system mode fails
Summary: pulseaudio --system mode fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: K12LTSP
TreeView+ depends on / blocked
 
Reported: 2009-04-22 16:56 UTC by Warren Togami
Modified: 2009-04-22 20:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-04-22 20:51:41 UTC


Attachments (Terms of Use)

Description Warren Togami 2009-04-22 16:56:00 UTC
pulseaudio-0.9.15-10.fc11

Thin client running pulseaudio as system daemon, GNOME desktop running remotely over ssh tunnel.

                /usr/bin/pulseaudio --system \
                --exit-idle-time=-1 \
                --disable-shm \
                --no-cpu-limit \
                --resample-method=trivial \
                --high-priority \
                --log-target=syslog \
                -L module-detect \
                -L "module-esound-protocol-tcp auth-anonymous=1" \
                -L "module-native-protocol-tcp auth-anonymous=1" \
                -L module-volume-restore \
                -L module-rescue-streams \
                -L "module-native-protocol-unix auth-anonymous=1" \
                -n &

main.c: Running in system mode, but --disallow-exit not set!
main.c: Running in system mode, but --disallow-module-loading not set!
module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=0"): initialization failed.
module.c: Failed to load  module "module-alsa-source" (argument: "device_id=0"): initialization failed.
module-detect.c: failed to detect any sound hardware.
module.c: Failed to load  module "module-detect" (argument: ""): initialization failed.
main.c: Module load failed.
main.c: Failed to initialize daemon.

These parameters worked with pulseaudio in F-9 and F-10.  What changed in pulseaudio F-11?

Do we need to change parameters to pulseaudio system daemon?
Will these new parameters work with pulseaudio F-9 and F-10?

Comment 1 Lennart Poettering 2009-04-22 19:52:46 UTC
Looks like a permission problem. Could you please get me the full debug output with -vvvvvvvvv?

Comment 2 Warren Togami 2009-04-22 20:51:41 UTC
Permission problem, fixed elsewhere.


Note You need to log in before you can comment on or make changes to this bug.