Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4957 - lpd does not handle remote requests properly
Summary: lpd does not handle remote requests properly
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lpr
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 4949 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-07 18:13 UTC by Geoff Reedy
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-07 19:26:49 UTC


Attachments (Terms of Use)

Description Geoff Reedy 1999-09-07 18:13:27 UTC
I tried this before, but it seems to have gotten lost...

lpd attempts to create a null file, because a mktemp(3) call
fails since a memcpy apparently leaves the string without
six X charaters at the end of the string.  In this situation
mktemp(3) returns a NULL string.  I have a patch, but
bugzilla says I should refer a bug number.

Comment 1 Bill Nottingham 1999-09-07 19:26:59 UTC
*** Bug 4949 has been marked as a duplicate of this bug. ***

lpd does not spool remote requests properly, because it is
trying to create a temprorary file, but fails.  Upon further
inspection, it is because of a mktemp(3) call returning
NULL, and then an attempt to create a file with this name.
This, of course, fails and the print job is not spooled
correctly, causing it not to print.  I have a patch, but
bugzilla wants there to be a bug report before submiting a
patch.

------- Additional Comments From pbrown@redhat.com  09/07/99 13:10 -------
Can you please attach your patch now?This has already been fixed in the latest lpd in Raw Hide.


Note You need to log in before you can comment on or make changes to this bug.