Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4949 - lpd doesn't spool remote requests
Summary: lpd doesn't spool remote requests
Keywords:
Status: CLOSED DUPLICATE of bug 4957
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lpr
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-07 05:33 UTC by Geoff Reedy
Modified: 2014-03-17 02:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-07 19:26:23 UTC


Attachments (Terms of Use)

Description Geoff Reedy 1999-09-07 05:33:58 UTC
lpd does not spool remote requests properly, because it is
trying to create a temprorary file, but fails.  Upon further
inspection, it is because of a mktemp(3) call returning
NULL, and then an attempt to create a file with this name.
This, of course, fails and the print job is not spooled
correctly, causing it not to print.  I have a patch, but
bugzilla wants there to be a bug report before submiting a
patch.

Comment 1 Preston Brown 1999-09-07 17:10:59 UTC
Can you please attach your patch now?

Comment 2 Bill Nottingham 1999-09-07 19:26:59 UTC
*** This bug has been marked as a duplicate of 4957 ***


Note You need to log in before you can comment on or make changes to this bug.