Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4945 - Netscape 4.61-6 does not load
Summary: Netscape 4.61-6 does not load
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: netscape
Version: 1.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-06 22:17 UTC by jbotha
Modified: 2014-03-17 02:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-20 17:10:26 UTC


Attachments (Terms of Use)

Description jbotha 1999-09-06 22:17:02 UTC
Following error message when starting netscape 4.61-6:
/usr/lib/netscape-communicator: error in loading shared
libraries
/usr/X11R6/lib/libXt.so.6: undefined symbol: __rawmemchr

Last working version was 4.61-4.
Could the problem be related to compat-glibc?

Comment 1 Bill Nottingham 1999-09-07 14:01:59 UTC
Did you change the /usr/bin/netscape wrapper at all?

Comment 2 Bill Nottingham 1999-09-17 22:18:59 UTC
Also, what is the output of:
rpm -qi XFree86-libs
rpm -V XFree86-libs

Comment 3 jbotha 1999-09-18 05:15:59 UTC
Well, I had some time to dick around with it tonight, and it turns
out my original hunch was almost correct - the problem is with compat-
libs, or, more precisely, with rpm-3.0.3-0.26.  Turns out that rpm
doesn't know how to do %files /usr/%{buildarch}-glibc20-linux/lib/*.
The files are placed inside /usr/%{buildarch}-glibc20-linux/lib in
the .rpm, instead of in /usr/i386-glibc20-linux/lib.  Changing the
spec file to read %files /usr/i386-glibc20-linux/lib/* still does not
help!
Should I log a new bug for rpm?

Comment 4 Bill Nottingham 1999-09-18 18:52:59 UTC
So what you're saying is that the compat libs were actually not
where netscape was looking for them, correct?

What probably needs to happen is %{buildarch} needs to be
changed to %{target_cpu} in the spec file. (The original
packages were built with RPM 2.5.)

Comment 5 jbotha 1999-09-20 03:18:59 UTC
Yes, that's what I was saying.  But, I tried to rebuild compat-libs-
5.2-2 with %{_target_cpu}  (%{target_cpu} does not work) and I am
still getting the __rawmemchr error from Netscape.  Now, since my
compat-libs-5.2-1 binary rpm from Hedwig works, it brings us back to
your question:
rpm -q XFree86-libs => XFree86-libs-3.3.5-1.6.0
rpm -V XFree86-libs checks OK.
And, no, I did not change the wrapper.

That's about all I have time for tonight...

Comment 6 Bill Nottingham 1999-09-20 15:34:59 UTC
Oops.... you can't build the compat-libs on a 6.0 system,
as that will just build a bunch of glibc-2.1 libs. That's
probably where your problem is.

Comment 7 jbotha 1999-09-20 15:48:59 UTC
Yip, that would be it.


Note You need to log in before you can comment on or make changes to this bug.