Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4879 - Telnet from RH6 to 3Com Office Connect routers.
Summary: Telnet from RH6 to 3Com Office Connect routers.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: telnet
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-03 09:32 UTC by chrisgorringe
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-16 13:07:42 UTC


Attachments (Terms of Use)

Description chrisgorringe 1999-09-03 09:32:35 UTC
I am posting this here because RH Installation support
suggest that it may be a bug.

My original posting is this:-

With Redhat 5.1 and 5.2, we have no problem telneting to
3Com Office Connect routers. With 6.0, we can telnet to
other hosts but not to 3Com OC routers. We have tried 3
different routers and 4 different installations of RH 6.0.

Using a packet analyzer, the problem looks like the fact
that the structure of the SYN packet to start the
conversation is larger on 6.0 than 5.x. On 6.0, the
diffences appear to be that the SYN flag is a Handshake
Request (A002) and a larger number of Option bytes and on
5.x, the SYN flag is a Handshake Request (6002) and only 4
byes of Option data.

I have included the two packet traces; the one with just a
single packet is the RedHat 6.0 - it repeats the packet a
number of times, and the other one is from RedHat 5.1.

Can you tell me what I need to change to get this to work.
We have the latest firmware versions in the 3Com boxes
(

Comment 1 Bernhard Rosenkraenzer 2000-02-16 13:07:59 UTC
Does the new telnet version in rawhide (or the 6.2 beta) fix this?

Comment 2 Jeff Johnson 2000-07-27 20:20:46 UTC
Closed for lack of input.

Comment 3 chrisgorringe 2000-07-27 21:02:37 UTC
The problem is caused by the tcp_timestamps in /proc/sys/net/ipv4. 3Com routers 
cannot handle timestamped ip packets. By disabling this, you can successfully 
telnet a 3Com router. However, 3com don't really make routers any more.


Note You need to log in before you can comment on or make changes to this bug.