Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 487588 - F-11 kernel nfs modules not pulled into initrd
Summary: F-11 kernel nfs modules not pulled into initrd
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: K12LTSP F11Blocker, F11FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2009-02-26 21:03 UTC by Warren Togami
Modified: 2009-04-23 19:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-04-23 19:14:35 UTC


Attachments (Terms of Use)

Description Warren Togami 2009-02-26 21:03:33 UTC
kernel-2.6.29-0.157.rc6.git2.fc11.i586
mkinitrd-6.0.78-1.fc11.i586

root=dhcp boot fails here...

Loading nfs module
nfs: Unknown symbol nlmclnt_proc
nfs: Unknown symbol nfsacl_decode
nfs: Unknown symbol nfsacl_encode
nfs: Unknown symbol svc_gss_principal
nfs: Unknown symbol nlmclnt_init
nfs: Unknown symbol nlmclnt_done

--with-avail="nlmclnt_proc nfsacl_decode nfsacl_encode svc_gss_principal nlmclnt_init nlmclnt_done" fails to pull these modules into the initrd.

Comment 1 Warren Togami 2009-02-26 22:00:27 UTC
Hey Steve, do you know if anything in the upstream kernel changed that might have caused this?  Does mkinitrd have to somehow adapt, or is this a kernel bug?

Comment 2 Steve Dickson 2009-02-27 16:55:46 UTC
The problem is the lockd, auth_rpcgss and nfs_acl modules are not getting loaded 
which should happen auto-magically when the nfs module is loaded...

Has something change in how modules are getting loaded or what modules
exist in initrd??

Comment 3 Warren Togami 2009-02-27 17:00:09 UTC
initrd rootfs mount is only NFSv3 with nolock.  I don't know if something changed in mkinitrd or kernel to cause this.

Comment 4 Steve Dickson 2009-02-27 19:51:55 UTC
I would think just adding the lockd, auth_rpcgss and nfs_acl modules
to the initrd would take care of the problem....

Comment 5 Jeremy Katz 2009-02-27 20:45:34 UTC
They should be module deps to pull in lockd, auth_rpcgss and nfs_acl.

Warren -- can you look at what modules get included in the initramfs both with and without the additional modules being explicitly specified?

Comment 6 Warren Togami 2009-04-23 19:14:35 UTC
This seems to have gone away.


Note You need to log in before you can comment on or make changes to this bug.