Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 487560 - Broken handling of relative mouse grab mode
Summary: Broken handling of relative mouse grab mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk-vnc
Version: 5.4
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Daniel Berrange
QA Contact: Martin Jenner
URL:
Whiteboard:
: 432232 (view as bug list)
Depends On:
Blocks: 223805
TreeView+ depends on / blocked
 
Reported: 2009-02-26 18:11 UTC by Daniel Berrange
Modified: 2009-09-02 09:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 09:48:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1301 normal SHIPPED_LIVE gtk-vnc bug fix update 2009-09-01 10:05:55 UTC

Description Daniel Berrange 2009-02-26 18:11:34 UTC
Description of problem:
The current GTK-VNC code has a couple of problems with the way it handles relative mouse mode in VNC described here

http://mail.gnome.org/archives/gtk-vnc-list/2009-February/msg00003.html

These cause an 'invisible wall' problem as per bug 223805

This is fixed upstream here:

http://git.gnome.org/cgit/gtk-vnc/commit/?id=85279b75576fcce7465754a8cc7b21cb6db5c355

Version-Release number of selected component (if applicable):
gtk-vnc-0.3.2-3.el5

How reproducible:
Difficult, but common

Steps to Reproduce:
1. Use a guest virtual machine for a while
2.
3.
  
Actual results:
At some point the mouse cursor will hit an invisible wall, preventing movement over some part of the guest console desktop

Expected results:


Additional info:

Comment 1 Daniel Berrange 2009-04-01 15:06:43 UTC
Fix built into gtk-vnc-0.3.8-1.el5

Comment 2 Daniel Berrange 2009-04-01 15:10:14 UTC
*** Bug 432232 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2009-09-02 09:48:41 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1301.html


Note You need to log in before you can comment on or make changes to this bug.