Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4870 - RPM Test for Read-Only File System
Summary: RPM Test for Read-Only File System
Keywords:
Status: CLOSED DUPLICATE of bug 4098
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-03 00:08 UTC by Jason Bucata
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-03 17:32:45 UTC


Attachments (Terms of Use)

Description Jason Bucata 1999-09-03 00:08:30 UTC
It would be nice if RPM would, in addition to all of the
other checking that I know it does before attempting an
install, check all of the affected file systems and see if
any of them are mounted read-only.  It's rather annoying at
best, dangerous at worst, to have a package partially
install and then fail in the middle as a result of a
read-only file system that I forgot to remount before
attempting the install.  Since I mount most of my
filesystems read-only this becomes quite annoying.

At *least* if rpm --test would say something (since I do run
it with --test before running for real), that would be a
step in the right direction.

Comment 1 Jeff Johnson 2001-01-08 16:16:53 UTC

*** This bug has been marked as a duplicate of 4098 ***


Note You need to log in before you can comment on or make changes to this bug.