Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4846 - gdm.pid...is this a bug?
Summary: gdm.pid...is this a bug?
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-02 03:43 UTC by watha
Modified: 2017-08-24 02:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-02 17:17:32 UTC


Attachments (Terms of Use)

Description watha 1999-09-02 03:43:33 UTC
Some background: I'm running RedHat 6 on an old DEC Pentium
90 computer with
onboard S3 video.

While working to set up Samba on my computer, I tried to
restart
Enlightenment.  The system crashed, and I had no choice but
to power down in
order to reboot.  Now it's doing something utterly bizarre.

I'm set to runlevel 5, so it's supposed to go into x
automatically.  The
computer tries to do so...or at least I think that's what
it's doing.  The
screen just keeps flashing on and off, over and over, for
about a minute.
When it finally stops, this message appears, over and over:

"According to /var/run/gdm.pid, gdm was already running
(697), but seems to
have been murdered mysteriously."

This appears about a dozen times, with different job
numbers each time.
Then at the end:

"INIT: Id "x" respawning too fast: disabled for 5 minutes."

Sure enough, the cycle repeats itself every five minutes.

When I try to go into X manually, I get an error message
like this:

Fatal server error:
Cannot open mouse (No such device)

I do have a mouse, and it worked fine up till the system
crash.

Now...what does all this mean?  Help!  Please....?

Comment 1 Michael K. Johnson 1999-09-25 05:11:59 UTC
Have you tried removing /var/run/gdm.pid?

(We're probably moving to a newer version of gdm for the
upcoming release of Red Hat Linux 6.1, which may be the
best way to fix the bug.)

------- Additional Comments From   10/29/99 23:11 -------
This also happens on my AlphaStation 4/200 machine running RedHat 6.0
Linux.  Something is killing the X font server (xfs), and gdm can't
start a new session until xfs is restarted.  If you log in through
another terminal when this is happening as root and
type "/etc/rc.d/init.d/xfs start" then the problem disappears. (once
anyways).  I do not know why xfs is dieing.  There is no good
information in the logs.

Comment 2 mkp 1999-11-01 19:32:59 UTC
The ``murdered mysteriously'' message is informal and not critial. gdm
gracefully handles when a pidfile exists but no daemon is running.

I have implemented /sbin/init-like repawn control to my working tree
to avoid restarting X servers.

Regarding the xfs bug: No clue, but I've seen it on several machines.

Comment 3 Elliot Lee 1999-11-02 17:17:59 UTC
A compiler bug causes xfs to crash under certain conditions. This one
is fixed in 6.1.

Comment 4 openshift-github-bot 2017-08-24 02:00:54 UTC
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/58b6a26d7f64d15036f0cc8b979e446874c51fc3
Merge pull request #5064 from bfallonf/aggre_4846

Issue 4846 Fixed link to aggregated logging yaml


Note You need to log in before you can comment on or make changes to this bug.