Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4819 - "modprobe sound" will not load sound modules
Summary: "modprobe sound" will not load sound modules
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-01 03:11 UTC by vectro
Modified: 2014-03-17 02:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-25 02:19:39 UTC


Attachments (Terms of Use)

Description vectro 1999-09-01 03:11:21 UTC
Technically this is a problem with modprobe, but the
workaround involves initscripts.

The problem is that, while kerneld/kmod will look for the
"sound" module alias when trying to automatically load new
sound modules, there is a real module called sound.

It seems that modprobe checks for the real module before the
alias, and so the "modprobe sound" command in the
initscripts loads only the sound module, and not the alias
(which is what you really want).

One workaround is to use some other alias instead. This
patch uses the alias "wave". Naturally this requires a
corresponding change in conf.modules.

--- /tmp/rc.sysinit     Tue Aug 31 20:07:06 1999
+++ /etc/rc.d/rc.sysinit        Tue Aug 31 20:08:32 1999
@@ -189,8 +189,8 @@

 # load sound modules
 if [ -n "$USEMODULES" ]; then
-   if grep -s -q "^alias sound" /etc/conf.modules ; then
-      action "Loading sound module" modprobe sound
+   if grep -s -q "^alias wave" /etc/conf.modules ; then
+      action "Loading wave module" modprobe wave
    fi
    if grep -s -q "^alias midi" /etc/conf.modules ; then
       action "Loading midi module" modprobe midi

Comment 1 Bill Nottingham 1999-09-01 20:22:59 UTC
This has been working fine here for quite a while ; what
does your /etc/conf.modules look like?

Comment 2 vectro 1999-09-01 21:39:59 UTC
Hope this will help. Note that I changed the "sound" to "wave" in
/etc/conf.modules _after_ reporting this bug (and applying the
included patch.) This change _appears_ to have fixed the issue.

[vectro@crafter vectro]$ rpm -q kernel initscripts redhat-release
kernel-2.0.36-0.7
initscripts-4.16-1
redhat-release-6.0-1
[vectro@crafter vectro]$ cat /proc/version
Linux version 2.2.10 (root@crafter.th.org) (gcc version egcs-2.91.66
19990314/Linux (egcs-1.1.2 release)) #16 Mon Jun 14 15:18:59 PDT 1999
[vectro@crafter vectro]$ uname -a
Linux crafter.house 2.2.10 #16 Mon Jun 14 15:18:59 PDT 1999 i686
unknown
[vectro@crafter vectro]$ cat /etc/conf.modules
alias eth0 3c509
options 3c509 irq=9
options 3c59x irq=9

alias parport_lowlevel parport_pc
options parport_pc io=0x3bc irq=7
options lp parport=0
alias parport_lowlevel parport_pc

pre-install pcmcia_core /etc/rc.d/init.d/pcmcia start

alias wave sb
options sound dmabuf=1
options opl3 io=0x388
alias midi awe_wave
post-install awe_wave /bin/sfxload /etc/midi/GU11-ROM.SF2
options sb io=0x220 irq=5 dma=1 dma16=5 mpu_io=0x330

Comment 3 Bill Nottingham 1999-09-01 21:57:59 UTC
That should work fine with 'alias sound sb'.
What's the error that you get?

(You might want to change the 'options sound dmabuf=1' line
to 'pre-install sound /sbin/insmod sound dmabuf=1', though...)

Comment 4 maavl 1999-11-26 10:28:59 UTC
I think the problem is with the version of modutils used; see bug 7343I think the problem is zith the version of modutils used; see bug 7343


Note You need to log in before you can comment on or make changes to this bug.