Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4802 - Glibc upgrade mangles /etc/localtime dereferencing
Summary: Glibc upgrade mangles /etc/localtime dereferencing
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-31 13:35 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-31 19:58:35 UTC


Attachments (Terms of Use)

Description Pekka Savola 1999-08-31 13:35:35 UTC
It seems Glibc upgrade de-referenced my /etc/localtime
symbolic links (from /usr/share/zoneinfo/Europe/Helsinki)
pretty badly:

-- `date` --
Tue Aug 31 13:30:51 /etc/localtime 1999
------------

Copying the correct zoneinfo file by hand and renaming it
to localtime seemed to work fine:

-- `date`  --
Tue Aug 31 16:31:55 EEST 1999
-------------

Comment 1 Bill Nottingham 1999-08-31 17:51:59 UTC
Do you know when this was done? glibc's script doesn't dereference
the symlink ; that's done in timeconfig/initscripts.
The %post seems to work OK currently.

Comment 2 Pekka Savola 1999-08-31 19:01:59 UTC
I'm not 100% sure, but I think the update before the last (w/ autorpm)
from ftp.sunet.se mirror was conducted at:
Fri Aug 20 12:37:27 (GMT+2)

And the last either
Tue Aug 24 12:24:26 or
Wed Aug 25 00:11:09

I couldn't reproduce this playing w/ glibc, timeconfig or initscripts.

HTH.

Comment 3 Bill Nottingham 1999-08-31 19:58:59 UTC
OK.

I think that at some point the %post was broken in
initscripts/timeconfig, but it's since been fixed. However,
you might have upgraded during the broken time.

In the meantime, I'll mark this as fixed for the next release.


Note You need to log in before you can comment on or make changes to this bug.