Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 480095 - Taskomatic broken in 0.4
Summary: Taskomatic broken in 0.4
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mike McCune
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space04
TreeView+ depends on / blocked
 
Reported: 2009-01-15 00:11 UTC by Mike McCune
Modified: 2009-01-22 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-22 16:31:46 UTC


Attachments (Terms of Use)

Description Mike McCune 2009-01-15 00:11:34 UTC
Error when starting:

STATUS | wrapper  | 2009/01/14 19:09:37 | --> Wrapper Started as Daemon
STATUS | wrapper  | 2009/01/14 19:09:37 | Launching a JVM...
INFO   | jvm 1    | 2009/01/14 19:09:39 | Wrapper (Version 3.1.2) http://wrapper.tanukisoftware.org
INFO   | jvm 1    | 2009/01/14 19:09:39 | 
INFO   | jvm 1    | 2009/01/14 19:09:40 | 2009-01-14 19:09:40,310 [Wrapper-Connection] WARN  com.redhat.rhn.taskomatic.core.SchedulerKernel - No schedule found for com.redhat.rhn.task.CleanCurrentAlerts. Skipping...
INFO   | jvm 1    | 2009/01/14 19:09:40 | 2009-01-14 19:09:40,311 [Wrapper-Connection] WARN  com.redhat.rhn.taskomatic.core.SchedulerKernel - No schedule found for com.redhat.rhn.task.SynchProbeState. Skipping...
INFO   | jvm 1    | 2009/01/14 19:09:40 | 2009-01-14 19:09:40,356 [Wrapper-Connection] ERROR com.redhat.rhn.taskomatic.core.SchedulerKernel - com.redhat.rhn.task.SatelliteCertificateCheck
INFO   | jvm 1    | 2009/01/14 19:09:40 | java.lang.ClassNotFoundException: com.redhat.rhn.task.SatelliteCertificateCheck
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at java.security.AccessController.doPrivileged(Native Method)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at com.redhat.rhn.taskomatic.core.SchedulerKernel.scheduleJobs(SchedulerKernel.java:230)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at com.redhat.rhn.taskomatic.core.SchedulerKernel.configure(SchedulerKernel.java:189)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at com.redhat.rhn.taskomatic.core.TaskomaticDaemon.onStartup(TaskomaticDaemon.java:84)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at com.redhat.rhn.taskomatic.core.BaseDaemon.startupWithOptions(BaseDaemon.java:189)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at com.redhat.rhn.taskomatic.core.BaseDaemon.start(BaseDaemon.java:54)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at org.tanukisoftware.wrapper.WrapperManager.startInner(WrapperManager.java:1786)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at org.tanukisoftware.wrapper.WrapperManager.handleSocket(WrapperManager.java:2385)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at org.tanukisoftware.wrapper.WrapperManager.run(WrapperManager.java:2697)
INFO   | jvm 1    | 2009/01/14 19:09:40 | 	at java.lang.Thread.run(Thread.java:636)
FATAL  | jvm 1    | 2009/01/14 19:09:40 | com.redhat.rhn.task.SatelliteCertificateCheck
com.redhat.rhn.common.conf.ConfigException: com.redhat.rhn.task.SatelliteCertificateCheck
	at com.redhat.rhn.taskomatic.core.SchedulerKernel.scheduleJobs(SchedulerKernel.java:246)
	at com.redhat.rhn.taskomatic.core.SchedulerKernel.configure(SchedulerKernel.java:189)
	at com.redhat.rhn.taskomatic.core.TaskomaticDaemon.onStartup(TaskomaticDaemon.java:84)
	at com.redhat.rhn.taskomatic.core.BaseDaemon.startupWithOptions(BaseDaemon.java:189)
	at com.redhat.rhn.taskomatic.core.BaseDaemon.start(BaseDaemon.java:54)
	at org.tanukisoftware.wrapper.WrapperManager.startInner(WrapperManager.java:1786)
	at org.tanukisoftware.wrapper.WrapperManager.handleSocket(WrapperManager.java:2385)
	at org.tanukisoftware.wrapper.WrapperManager.run(WrapperManager.java:2697)
	at java.lang.Thread.run(Thread.java:636)
Caused by: java.lang.ClassNotFoundException: com.redhat.rhn.task.SatelliteCertificateCheck
	at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
	at com.redhat.rhn.taskomatic.core.SchedulerKernel.scheduleJobs(SchedulerKernel.java:230)
	... 8 more

Comment 1 Mike McCune 2009-01-15 00:19:51 UTC
bad config.  we moved this class to:

com.redhat.rhn.taskomatic.task.SatelliteCertificateCheck


Note You need to log in before you can comment on or make changes to this bug.