Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 479893 - Live Hard Drive install shouldn't mangle the ifcfg-* files
Summary: Live Hard Drive install shouldn't mangle the ifcfg-* files
Keywords:
Status: CLOSED DUPLICATE of bug 461550
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: K12LTSP
TreeView+ depends on / blocked
 
Reported: 2009-01-13 21:33 UTC by Warren Togami
Modified: 2009-01-15 15:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-15 15:30:00 UTC


Attachments (Terms of Use)

Description Warren Togami 2009-01-13 21:33:54 UTC
/etc/sysconfig/network-scripts/ifcfg-ltspbr0

k12linux.org Live Server spin has an installed file defining a private bridge.  This bridge runs during LiveCD runtime just fine.  However "Install to Hard Drive" rewrites this file to a nearly blank state removing the IP address and other options needed.

dcantrell said Live Hard Drive install should skip this ifcfg-* rewriting step.

Comment 1 David Cantrell 2009-01-13 21:41:32 UTC
We need to do this:

---
 network.py |    3 +++
 1 files changed, 3 insertions(+), 0 deletions(-)

diff --git a/network.py b/network.py
index b50605e..98cde5d 100644
--- a/network.py
+++ b/network.py
@@ -516,6 +516,9 @@ class Network:
         return False
 
     def write(self, instPath='', anaconda=None):
+        if flags.livecdInstall:
+            return
+
         if len(self.netdevices.values()) == 0:
             return
 
-- 
1.6.0.3

Comment 2 David Cantrell 2009-01-15 15:30:00 UTC

*** This bug has been marked as a duplicate of bug 461550 ***


Note You need to log in before you can comment on or make changes to this bug.