Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 479684 - [NetApp 4.8 bug] online resize of filesystem does not work (user space)
Summary: [NetApp 4.8 bug] online resize of filesystem does not work (user space)
Keywords:
Status: CLOSED DUPLICATE of bug 352421
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath
Version: 4.8
Hardware: All
OS: Linux
high
high
Target Milestone: beta
: ---
Assignee: Ben Marzinski
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On: 454872
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-01-12 14:18 UTC by Andrius Benokraitis
Modified: 2015-07-14 04:27 UTC (History)
30 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
There is a new multipathd command, "resize map <mapname>". This command is used to cause dm-multipath to adjust to a change in the size of the underlying block storage device. Use the the following procedure, after you resize the underlying block device: # multipathd -k multipathd> del path <path-name> ok multipathd> add path <path-name> ok <repeat for each path to the device> multipathd> resize map <map name> For example: # multipath -ll mpath-resize-test (36090a018c032e4801e8e341700008039) dm-5 EQLOGIC,100E-00 [size=2.0G][features=0][hwhandler=0][rw] \_ round-robin 0 [prio=1][active] \_ 2:0:0:0 sdd 8:48 [active][ready] \_ round-robin 0 [prio=1][enabled] \_ 3:0:0:0 sdc 8:32 [active][ready] # multipathd -k multipathd> del path sdc ok multipathd> add path sdc ok multipathd> del path sdd ok multipathd> add path sdd ok multipathd> resize map mpath-resize-test ok There is one restriction on the use of the device mapper multipath resize command. You can not resize a device-mapper device while there commands queued to that device. That is, do not use the resize command when no_path_retry is set to "queue", and there are no active paths to the device.
Clone Of: 455692
Environment:
Last Closed: 2009-01-23 00:41:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Andrius Benokraitis 2009-01-12 14:20:56 UTC
Cloned from 5.3 - similar to the kernel space, this is for the user space. Please edit the release notes if appropriate, they were copied over from 5.3 as well.

This bug depends on the kernel bug 454872.

Comment 2 Ben Marzinski 2009-01-23 00:41:42 UTC

*** This bug has been marked as a duplicate of bug 352421 ***

Comment 3 Andrius Benokraitis 2009-01-23 17:18:25 UTC
NETAPP: please add yourselves to the duped bug, bug 352421 please, thanks!

Comment 4 nandkumar mane 2009-03-09 13:30:48 UTC
Verified in RHEL4.8 successfully.


Note You need to log in before you can comment on or make changes to this bug.